Rasa github code sample error

HI,

I am trying to download code from GitHub - RasaHQ/rasa: 💬 Open source machine learning framework to automate text- and voice-based conversations: NLU, dialogue management, connect to Slack, Facebook, and more - Create chatbots and voice assistants

I tried installing the packages from requirement.txt after that if i give make test, is not working.

Can someone suggest how to install and run the project in pycharm.

Hi @binuedwin! What error message do you get? In order to run the tests you should do the following

export PIP_USE_PEP517=false
pip3 install -r requirements-dev.txt
pip3 install -e .
make prepare-tests-ubuntu # Only on Ubuntu and Debian based systems
make prepare-tests-macos  # Only on macOS

Make sure to use pytest as test runner in PyCharm when executing the tests over there (preferences - python integrated tools).

Hi,

I am trying to run the Restaurant bot present in Rasa Github.

After executing 1. rasa train. when i execute rasa.shell i am getting the below error The path ‘models’ does not exist. Please make sure to use the default location (‘models’) or specify it with ‘–model’.

If rasa train finished successfully, you should have a models folder with a model present. Can you add the --debug flag to the command and paste the log output of the command here? Thanks.

hi,

Now i am able to run the rasa shell. But i am getting the below error

2019-09-19 11:05:06 ERROR rasa.core.processor - Encountered an exception while running action ‘action_search_restaurants’. Bot will continue, but the actions events are lost. Make su re to fix the exception in your custom code. 2019-09-19 11:05:08 ERROR rasa.core.processor - Encountered an exception while running action ‘action_suggest’. Bot will continue, but the actions events are lost. Make sure to fix t he exception in your custom code.

What is the log of the action server? It might be also helpful to start everything in debug mode (add --debug to the rasa shell and rasa run actions commands).

I meet the same problem ,can you tell me how to solve “The path ‘models’ does not exist”,thanks

@ymhsprint The error indicates that you command cannot found any model. If you don’t specify any model directory with the argument --model, it takes the default model path, which is models. If that is not present, the error is thrown. So make sure a model file exists and use the --model argument to point to it. For more information about the command line arguments see Command Line Interface.

yes,I know what you say.

in fact,models directory do exist ,when i run rasa shell with no parameters or rasa shell --model models/xxx.tar.gz ,it take the same problem.

I train the model in my server and copy model to local pc, I don’t know if it matters,I try to reinstall the dependencies

@ymhsprint As you error seems not to be related to the problem of @binuedwin can you please open a new thread? Feel free to tag me. And please also provide the directory structure of the project you are working in and the rasa version you are using. Thanks.

I can’t understand what you mean ‘open a new thread’,here is my project’s structure of directory and rasa version is 1.3.6

the image of error is as follows:

open a new thread

As your problem it not related to the original problem of this thread, I wanted you to start a new topic on the forum. You can start a new topic on the top right of https://forum.rasa.com/.

This is a different error as the one mentioned above. It seems like that your mitie named entity extractor is somehow broken. Your trained model cannot be loaded. Did you try to train the model again from scratch and start Rasa?