Rasa fails to load remote aws s3 model

Hi, After running over every possible post related to running a rasa rest service with a model from aws s3 I came to a dead end. It simply isn’t working and the documentation for it is too broad.

my envs:

export AWS_DEFAULT_REGION=“eu-central-1”

export AWS_SECRET_ACCESS_KEY=“secret…”

export AWS_ACCESS_KEY_ID=“secret…”

export BUCKET_NAME=“nlp.models”

export AWS_ENDPOINT_URL=“https://s3.eu-central-1.amazonaws.com/

execution command:

docker run -p 5005:5005 rasa/rasa run -m latest-model.tar.gz --enable-api --log-file out.log --remote-storage aws

The s3 file structure is plain simple:

s3 bucket called nlp.models (in frankfurt , eu-central-1) inside that bucket there’s 1 file: latest-model.tar.gz

My aws IAM permissions are set and verified with 10 other applications fetching from s3 from that machine.

This is not working guys, is the AWS_ENDPOINT_URL wrong? I tried with setting it to https://s3.amazonaws.com/ , with and with an ending slash. tried also with https://s3.eu-central-1.amazonaws.com/nlp.models with no success.

You must give a proper usage example, this isn’t the first feature that isn’t working.

The error response log: 2020-04-02 11:06:19 ERROR rasa.core.agent - Could not load model due to expected string or bytes-like object.

opened a github issue:

Please advise , Thank you