"No model found" rasa with docker

Hi,

I have a docker installation of Rasa. Whenever I run the docker-compose up command, I see several messages about registering my custom actions, and then an error saying "No model found. Train a model before running the server using rasa train".

I don’t understand this error, because I have already trained several models, that I can see under a “./models” folder.

Here is my docker-compose.yml :

docker-compose_forum

Thanks for all help/explanation provided

what does the content of your ./models/rasa_core folder look like?

Hi @erohmensing, thanks for your help !

Here is my rasa_core folder :

rasa_core_forum

Ah I see the issue, you’re using the rasa image but your models are in the old rasa_core format. You’ll have to retrain in rasa and then mount the volumes where those go (usually it is a .tar.gz file that gets auto-outputted to the models/ folder)

Thanks for your quick reply !

Hmm I think it could be useful to send you this :

models_forum

Here is my models folder, where there are my .tar.gz models (which are the ones I use). I am not sure why I have still rasa_core and rasa_nlu folder ?

Here is the command I use to train models : docker run -v $(pwd):/app rasa/rasa train --domain domain.yml --data data --config config/config.yml --out models --fixed-model-name evi5

Here is my docker-compose.yml, if it can be of any help :

docker-compose_forum

What should I do ?

Hm not sure why you have those folders either, but they’re probably not relevant. looks like you have tar models that should work in your /models folder, can you try mounting that one instead of the subfolder? so

volumes: 
  - ./models:/app/models

Thank you this was definitely an error in my docker-compose.yml.

But this now the output of the docker-compose up command :

I don’t really understand what happened here. Also I still have the error No model found. Train a model before running the server using rasa train. when I run docker run -it -v $(pwd):/app rasa/rasa run actions.

Is it also a volumes problem ?

Thanks again for your help

So the rasa shell command requires a terminal I/O so if you’re going to use it, you have to use the it flag. More info here: Running Rasa with Docker

Hello, I am not sure of what you meant here, I think I already use the -it flag in each command I use ? I am a bit stuck here. I will read Running Rasa with Docker again !

Hmm it doesn’t look like you’re using the it flag in your docker compose where it just says

command:
  - shell

Ok I understand, I thought you were talking about the *docker run… * commands. I tried to add this -it flag in the docker-compose but never achieved to get another result that “error : invalid choice”. I did not find in the tuorial how to add it, could you please explain me (I feel childish but could use some help !) ?

Oh sorry, you’re not childish, I actually read that wrong, you’re right, it does go in the docker run commands! Where are you running those commands? Can you copy paste the entire output please?

Alright alright ! Here is what I got when I run the docker-compose up :

Then here is what I got when I run docker run -it -v $(pwd):/app rasa/rasa run actions :

Also here is my endpoints.yml :

endpoints_forum

Tell me if I can provide you anything else !

Did you solve this problem?

@rasafan there’s a lot of information here, and the thread is old, if you are running into a similar issue it is probably better to start a new thread with your issue and all of the background information of your setup.

@erohmensing

I started it but nobody is responding to my issue…

Rasa Docker problem with training the model