Rasa_core_sdk not working

I am following tutorial given at Learn how to Build a Chatbot in Minutes using Rasa

Got code from GitHub - mohdsanadzakirizvi/iplbot: A basic chatbot to fetch ipl updates made using rasa

Trying to get custom actions working. Code : iplbot/actions.py at master · mohdsanadzakirizvi/iplbot · GitHub

Endopoints are specified as:

action_endpoint: url: “http://localhost:5055

I am on windows with rasa core version 0.13.7

In a windows command line window, I run: python -m rasa_core_sdk.endpoint --actions actions

It says: 2019-05-02 10:07:17 INFO main - Starting action endpoint server… 2019-05-02 10:07:17 INFO rasa_core_sdk.executor - Registered function for ’ action_match_news’. 2019-05-02 10:07:17 INFO main - Action endpoint is up and running. on ( ‘’, 5055)

I am now expecting that if I type “http://localhost:5001/” in browser, it should show something, right?

But no, it says: The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again.

Another experiment: I run following command from another windows command line: python -m rasa_core.run -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml

It errors out saying: 2019-05-02 10:09:51 ERROR rasa_core.actions.action - Failed to run custom ac tion ‘action_match_news’. Action server responded with a non 200 status code of 404. Make sure your action server properly runs actions and returns a 200 once t he action is executed. Error: 404 Client Error: NOT FOUND for url: http://localh ost:5055/ 2019-05-02 10:09:51 ERROR rasa_core.processor - Encountered an exception whi le running action ‘action_match_news’. Bot will continue, but the actions events are lost. Make sure to fix the exception in your custom code.

Not sure what is going on. Is there any proxy issue? How to fix it? How to get this simple example working?

Hello, it seems that rasa core is not able to find rasa core sdk endpoint, Please check endpoints.yml
Please feel free to use example endpoints.yml file from here

1 Like

Specifying endpoints as suggested, worked!! Thanks.