Rasa core model response in link form

After creating rasa core model, When I am running python -m rasa_core.run -d models/dialogue command it said Bot loaded. Type a message and press enter (use ‘/stop’ to exit): but when I type some message it shows some link like: - - [2018-09-12 10:05:43] “POST /webhooks/rest/webhook?stream=true&token= HTTP/1.1” 200 122 0.102086 Can anyone help me with this? Screenshot%20from%202018-09-12%2010-59-30

The POST message simply tells you that the message ‘hi’ was sent to Rasa Core server. Do you get any response back after it prints the POST message?

May not be related to this exactly, but are you using the NLU model to parse intputs and do you have any custom actions in your code? If you do, you should pass the nlu model and the endpoints parameter like the following:

python -m rasa_core.run -d models/dialogue -u models/current/nlu_model --endpoints endpoints.yml

Hi @Juste , Im facing the same issue while running the dialogue management model.Im following the same steps given in your readme file of weather-bot example using latest rasa nlu and rasa core. I have created a new demo project using your example weather bot with latest versions of rasa nlu and rasa core…

Error:: Bot loaded. Type a message and press enter (use ‘/stop’ to exit): get weather in chennai /home/hdpuser/sramperu/library_required/anaconda/lib/python3.6/site-packages/sklearn/preprocessing/label.py:151: DeprecationWarning: The truth value of an empty array is ambiguous. Returning False, but in future this will result in an error. Use array.size > 0 to check that an array is not empty. if diff: - - [2019-01-17 15:29:45] “POST /webhooks/rest/webhook?stream=true&token= HTTP/1.1” 200 154 0.175739

Im not getting a response from the server.Its like once in a while it gives response(the weather details) while most of the times it gives empty response… I wont find any details in the terminal where endpoint server is running when it wont give any response.

Can you show what command you are running?

Hi Abhishak,

  1. First i ran python nlu_model.py, it ran successfully.
  2. I started the custom action server by running python -m rasa_core_sdk.endpoint --actions actions
  3. I opened a new terminal and ran python dialogue_management_model.py Then the bot gets loaded ,once in a while it gives response,but most of the times it shows “POST /webhooks/rest/webhook?stream=true&token= HTTP/1.1” 200 154 0.175739

Can you run this command and tell me the output? I’ll be happy to hear.

python -m rasa_core.run -d models/dialogue -u models/current/nlu_model --endpoints endpoints.yml

I tried this command earlier also,but no response…

Are you getting your response during interactive learning?

no response.

show me screenshot.

first image shows the custom action server running second image shows no response to “get weather in chennai”

I think there may be an error with your code because action should have started it doesn’t matter if it succeed or fails but at-least it should have started.

You should start debug;

Follow these steps: Follow step by step procedure as mentioned in the docs using http server starting from NLU to Core if it works then try go to Python code and debug code using print or breakpoints. I think it may resolve your problem if not then ping me again.

My problem is that…It starts once in a while,gives the response also,but most of the time it wont give response at all

Try to increase epochs and if problem remains same then may be this problem is with less data so you have to increase your training set but first start with altering epochs.