Rasa.core.agent - Could not load model due to No module named 'scipy.sparse._coo'

Here is error message

I tried install scipy==1.7.3, but issue is still there. I’m running rasa server using docker-compose.

Here is my Dockerfile

FROM rasa/rasa:2.8.2

COPY . /app
USER root

RUN pip install --upgrade pip
RUN pip install --no-cache-dir -r requirements.txt
RUN pip install scipy==1.7.3
RUN python -m spacy download en_core_web_md 
RUN python -m spacy link en_core_web_md en

COPY ./data /app/data

RUN rasa train

VOLUME /app/data
VOLUME /app/models

CMD ["run", "-m", "/app/models", "--enable-api","--cors","*","--debug" ,"--endpoints", "endpoints.yml", "--log-file", "out.log", "--debug"]


rasa version 2.8.9 rasa sdk 2.8.2

Any idea please? @nik202

@jpark2111 you need to update the scipy to 1.8.0 and please ref this thread: No module named 'scipy.sparse._coo' · Issue #10908 · RasaHQ/rasa · GitHub

OR May be downgrade to 1.5.X ?

Note: Delete the older trained model and retrain it back

Good Luck!

scipy==1.8.0 worked for me!