Rasa actions error

Hi, @nik202 Actually I’m Following this link Build an AI voice assistant with Rasa Open Source and Mozilla tools | Rasa to integrate voice in my rasa bot but in the fourth step when i run rasa run actions --actions demo.actions it ends with error

Just two other things 1- can rasa read the voicemail sent from telegram or messenger? 2- can we use rasa with Node red? thanks a lot

@Fares Hi fares, sorry for the late reply. I hope you solved this issue?

Hi, actually I still blocked and confused! Any way, I find this Connect Your Rasa AI Assistant to Amazon Alexa and I succeed to create rasa voice bot with Amazon ALexa For now it still:

  • integrating the created rasa voice bot with Amazon ALexa in a web page
  • when i connect my rasa bot with Telegram or Facebook or WhatsApp my bot can understand a voicemail (this is the most important)

@Fares mean all sorted congratulations

Thanks :grinning:, but i still blocked :pensive:. Is there any possibility that rasa read a voicemail sent by channel (facebook, …). :pleading_face:

@Fares I don’t know Fares much on this voice game :stuck_out_tongue: I played text match :wink:

@ChrisRahme any expert suggestion on this Dr. Chris :slight_smile:

2 Likes

Ahaha thanks Nik but I’m far from being an expert :stuck_out_tongue_closed_eyes:

Does the “Failed to register error” still happen? If yes, I don’t have much time to try it out myself but I’ll try to find some time :slight_smile:

As for the voicemail, you can try using Custom Connectors but I don’t have more details. See if this post can help.

1 Like

@Fares I told you he have something in his pocket :slight_smile: better then me at least :frowning:

1 Like

Don’t say that Nik! :laughing: We need to combine our forces hahaha

Anyway, let’s not deviate from the conversation more :stuck_out_tongue:

1 Like

@ChrisRahme and nik thank you very much I will explore this path and i will give you the feedback :slightly_smiling_face:

1 Like

@ChrisRahme actually I’m facing this error RasaException: Failed to find input channel class for ‘socketio_connector.SocketIOInput’. Unknown input channel. Check your credentials configuration to make sure the mentioned channel is not misspelled. If you are creating your own channel, make sure it is a proper name of a class in a module.

When are you getting this error?

Maybe these will help you:

when i run this rasa run --enable-api -p 5005

@Fares can you share the credentials.yml file? and socketio_connector.py ?

credentials.yml (1.6 KB)

@Fares check this repo may be it will help: voicebot/socketio_connector.py at master · JustinaPetr/voicebot · GitHub

@Fares rasa run --enable-api -p 5005 --cors

OR

rasa run -m models --enable-api --cors "*" --debug

@Fares I am not sure about your socket.io section for connector one.

I downloaded the socketio_connector.py and I put it in my rasa project directory
and i run rasa run -m models --enable-api --cors “*” --debug but it still the same error