Problem with voice interface(frontend) while using deepspeech with Rasa

This issue is related to the post: How to build a voice assistant with open source Rasa and Mozilla tools. After following the tutorial and some tinkering I successfully set up the voice assistant which starts and runs. However, I am facing a problem with the frontend voice interface. It works extremely slow(10-15 secs to respond) or doesn’t work at all at times. Also, there is a problem of it being disconnecting and reconnecting for 1 second which is a noticeable interference. More information that i’d like to add is that it didn’t respond to the sara bot at all, I had to configure it for mood bot which is a basic one before it responded at all. I am running it locally in system with 8gigs of ram and i5 8th gen processor so I don’t this this should be a problem. Moreover, Initially I thought deepspeech STT might be at fault here, so I tried running the same setup on cmd prompt without the interface and it worked like charm which led me to believe the problem lies in interface.

Some information about my setup: OS: ubuntu 20.04 RAM: 8gb Processor: i5-8250U CPU Deepspeech version: 0.8.1 TTS: same as provided in tutorial

PS: I made the neccessary changes in the socketio_connector.py file for using updated deepspeech version(and it works).

I noticed some people in the forums posted about the same and are facing similar problem and any help would be appreciated :slight_smile:

1 Like