Problem with the formbot

This problem is with regards to the formbot example in rasaHQ github page. I did the following steps. PFA folder

  1. rasa init --no-prompt
  2. this created certain files
  3. updated the config file with formpolicy
  4. Replaced the data, domain, and action file with that of the formbot, since docker is not available in my system
  5. did not update the endpoints and credentials file…maintained them as they were formed via the first command 5.the data got trained without any errors
  6. But when i run rasa shell and type the statement which produces the intent request_restaurent it gives me the following error:- " Encountered an exception while running action ‘restaurant_form’. Bot will continue, but the actions events are lost. Make sure to fix the exception in your custom code"

actions.py (4.6 KB) config.yml (301 Bytes) credentials.yml (658 Bytes) domain.yml (2.0 KB) endpoints.yml (1.3 KB)

and the data files are nlu.md (8.4 KB) stories.md (4.2 KB) All these are contained within a folder along with the models folder

Did you run the action server with rasa run actions in another terminal before running rasa shell? If so, is there an error in the action terminal?

there is no error in the action terminal though… But in the rasa shell in the aforementioned separate command prompt , when I type the statement with an intent and the intended entity , it gives me the same error

Failed to connect to duckling http server. Make sure the duckling server is running and the proper host and port are set in the configuration. More information on how to run the server can be found on github: GitHub - facebook/duckling: Language, engine, and tooling for expressing, testing, and evaluating composable language rules on input strings. Error: HTTPConnectionPool(host=‘localhost’, port=8000): Max retries exceeded with url: /parse (Caused by NewConnectionError(’<urllib3.connection.HTTPConnection object at 0x000001F7F72927B8>: Failed to establish a new connection: [WinError 10061] No connection could be made because the target machine actively refused it’))

I am starting to loose confidence in the instructions so mentioned in your github page… can you please tell where I am going wrong with the implementation of formbot… I want to follow the same syntax flow that has been mentioned in the formbot to customize one of my own…In github: the instruction are as follows

But i encountered with the above error whenever I run those commands. … How can I trust the formbot has been coded correctly

@Narayanan the error is there, you are not running a duckling server. Duckling is used to pick up the number entities. You can download it via the github (as it says in the error), or if you have docker, you can just get the rasa/duckling image from docker hub and run it on the port listed in the config via the command docker run -p 8000:8000 rasa/duckling.