Rasa action server requests error while using docker compose docker

version: '3.0'
    image: rasa/rasa:2.7.0-full
      - 5005:5005
      - ./:/app
      - run
    image: rasa/rasa-sdk:2.7.0
      - 5055:5055
      - ./actions:/app/actions
    image: rasa/duckling:latest
      - 8000:8000

I’m doing a post request in my actions file in one of my actions using python request library I’m getting this error

 File "/opt/venv/lib/python3.8/site-packages/requests/adapters.py", line 516, in send
action_server_1  |     raise ConnectionError(e, request=request)
action_server_1  | requests.exceptions.ConnectionError: HTTPSConnectionPool(host='chat.bhanu.cyou', port=443): Max retries exceeded with url: /api/apps/public/646b8e7d-f1e1-419e-9478-10d0f5bc74d9/incoming (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7f7fffca7490>: Failed to establish a new connection: [Errno 111] Connection refused'))

I’m also facing issues with duckling as well

rasa_1           | 2021-07-11 18:24:50 ERROR    rasa.nlu.extractors.duckling_entity_extractor  - Failed to connect to duckling http server. Make sure the duckling server is running/healthy/not stale and the proper host and port are set in the configuration. More information on how to run the server can be found on github: https://github.com/facebook/duckling#quickstart Error: HTTPConnectionPool(host='localhost', port=8000): Max retries exceeded with url: /parse (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fab1e20c9d0>: Failed to establish a new connection: [Errno 111] Connection refused'))

My action endpoint

 url: "http://action_server:5055/webhook"

and my duckling URL in config

  - name: DucklingEntityExtractor
    url: http://duckling:8000

I don’t know where I’m doing mistake

I also tried creating docker images for my actions server accroding to docs

But I’m getting same error

Hey @nik202

I am only using requests library and rasa/rasa-sdk:2.7.0 image already has requests library installed

What error are you getting? Did you follow the instructions here?

1 Like

Hello Thanks for getting back,

I fixed it there was a small issues from server side.

1 Like