Problem Installing rasa 3.1.0 on Mac

Hi everybody,

I am trying to install Rasa on a new virtualenv, I am following the simple recommended steps:

pip install rasa

but it keeps on failing with the following message:

ERROR: Exception:
Traceback (most recent call last):
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_internal/cli/", line 173, in _main
    status =, args)
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_internal/cli/", line 203, in wrapper
    return func(self, options, args)
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_internal/commands/", line 315, in run
    requirement_set = resolver.resolve(
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_internal/resolution/resolvelib/", line 94, in resolve
    result = self._result = resolver.resolve(
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_vendor/resolvelib/", line 472, in resolve
    state = resolution.resolve(requirements, max_rounds=max_rounds)
  File "/Users/name_of_user/opt/anaconda3/envs/rasa3/lib/python3.8/site-packages/pip/_vendor/resolvelib/", line 383, in resolve
    raise ResolutionTooDeep(max_rounds)
pip._vendor.resolvelib.resolvers.ResolutionTooDeep: 2000000

Can anybody help ?

TIA Eden

@jusce17 did you create the Anaconda environment and then try to install Rasa 3.X? What steps did you perform so far can you briefly share them in points.

I created the anaconda env, activated it and try to install using pip install rasa

It worked now, although I am not sure what was the problem, I ran the following command and it worked :

pip3 install -U --user pip && pip3 install rasa