Installation of rasa x on MAC fails


I am new to this and trying to install this on my laptop (MacOS). Rasa was installed successfully but Rasa X not.

Following the instructions at Local Mode

pip3 install rasa-x --extra-index-url the above is failing with following error

==================== Error ================= Collecting pyasn1>=0.1.7 Using cached pyasn1-0.4.7-py2.py3-none-any.whl (76 kB) Using cached pyasn1-0.4.6-py2.py3-none-any.whl (75 kB) Using cached pyasn1-0.4.5-py2.py3-none-any.whl (73 kB) ERROR: Exception: Traceback (most recent call last): File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_internal/cli/”, line 224, in _main status =, args) File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_internal/cli/”, line 180, in wrapper return func(self, options, args) File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_internal/commands/”, line 321, in run reqs, check_supported_wheels=not options.target_dir File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_internal/resolution/resolvelib/”, line 122, in resolve requirements, max_rounds=try_to_avoid_resolution_too_deep, File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_vendor/resolvelib/”, line 445, in resolve state = resolution.resolve(requirements, max_rounds=max_rounds) File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_vendor/resolvelib/”, line 325, in resolve for item in self.state.criteria.items() File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_vendor/resolvelib/”, line 326, in if not self._is_current_pin_satisfying(*item) File “/Users/Admin/MSc/course5/venv/lib/python3.7/site-packages/pip/_vendor/resolvelib/”, line 193, in _is_current_pin_satisfying for r in criterion.iter_requirement() AttributeError: ‘NoneType’ object has no attribute ‘iter_requirement’

Any pointers appreciated

Thanks, Abhilash.


I experience the same issue installing Rasa X in a python 3.7 anaconda 3 environment. Rasa is up and running (Rasa shell works), installing Rasa X does not work, though. Could it be related to the too new pip version (20.3.3)? Here’s my Rasa version:

Rasa Version : 2.2.4, Rasa SDK Version : 2.2.0, Rasa X Version : None, Python Version : 3.7.9, Operating System : Darwin-17.7.0-x86_64-i386-64bit, Python Path : /Applications/anaconda3/envs/py37/bin/python

1 Like

hi I got the same problem. AttributeError: ‘NoneType’ object has no attribute ‘iter_requirement’. which result in the later response. when I initiate the “rasa x” command in my tutorial-knowledge-base directory, MissingDependencyException: Rasa X does not seem to be installed, but it is needed for this CLI command. You can find more information on how to install Rasa X in local mode in the documentation: Local Mode

Same error on fedora server 33

Same here as well. On a mac.

See also issue below!

For me, downgrading the pip version worked: $ python -m pip install pip==20.2.4

1 Like

And led to another major problem with the domain_path in as reported over here:

So more or less have to wait to next update from Rasa?

I don’t know whether this is necessary. Installing rasa 2.1 and rasa x 0.34 worked for me (with python 3.7 and pip 20.2.4) so far. The pip version raised some errors (see here for more details), but I don’t think this is a serious matter. Here are my versions:

pip version: 20.2.4

Rasa Version : 2.1.0, Rasa SDK Version : 2.2.0, Rasa X Version : 0.34.0, Python Version : 3.7.9, Operating System : Darwin-17.7.0-x86_64-i386-64bit, Python Path : /Applications/anaconda3/envs/venv/bin/python

downgrade rasa into 2.2.2 without any other change also works for my mac.

1 Like

Not work for me

Downgrading did the trick for me. Thanks. :slight_smile:

1 Like

I’m on rasa 2.2.3, it’s working fine for me. :+1: :+1: