Problem in running custom action and rasa shell in same command


while running “rasa run actions & rasa shell” command ,I get struck here:

2019-11-08 11:45:34 INFO rasa_sdk.endpoint - Starting action endpoint server… 2019-11-08 11:45:34 INFO rasa_sdk.executor - Registered function for ‘action_joke’. 2019-11-08 11:45:34 INFO rasa_sdk.endpoint - Action endpoint is up and running on http (‘’, 5055)

where as according the tutorial YouTube ,it should work fine.

What could be possible reason(s) for it?


Although when I run “rasa run actions” and “rasa shell” separately it works fine.

So why am I not able to run them in same command?


did you found any solution for your question… If you found please let me know…

Did you run them separately at the same time? Coz mine is not working even though i run them separately

Hi @hellen17,

I ran them in two different command prompts consecutively. Once “rasa run actions” command was working i.e action server was running, at that time I ran “rasa shell” command in another instance of command prompt.