Policy_name = policy.pop("name") KeyError: 'name'



Im trying to recreate GitHub - RasaHQ/tutorial-knowledge-base: Integrating Rasa with a knowledge base to encode domain knowledge and resolve entities , but im facing errors

Python 3.6.6 Rasa 1.7.0 rasa-sdk==1.7.0

@carltondaniel Hello, two pointers and suggestion.

  1. You need to update the rasa to at least 2.8.1 and rasa-sdk to 2.8.1
  2. In domain.yml the template: is deprecated now we are using:

  - text : "Hello"


Just update the rasa and updates the code as per new syntax, I am sure you will be able to re-create the mention gituhub repo. I will encourage create the new environment and use the mention version as mentioned in requirements.txt.

hi NIK i tried to migrate Version Migration Guide to newer version was able to train the nlu and core successfully , when i type hi the bot understands the intent as greet and replies but after that nothing works , no error . please find the necessary files along with graken deb files knowledge_base_migrate - Google Drive doubt.pdf (491.0 KB) i have attached all the necessary documents for your reference Thank in advance

@carltondaniel please share the config.yml file as a reference.


Here is the config file , but all the required files are in the drive link for your reference , https://drive.google.com/drive/folders/1LmI8kMqAZhj2VXTnmLr6ykdTpetcRO3j?usp=sharing and the steps followed is http://forum.rasa.com/uploads/short-url/eHyxD007jTBmRqOW29LwGZfnbW8.pdf

@carltondaniel please always mention me with @ and nik202 for fast reply.

can you share me now what is your rasa --version?

Note: While using the migrate from one version to another can change the .md format to .yml format but in case of config.yml you have to manually need to update the polices and pipelines for your use case.

Try update this in your config.yml and then run ( delete the older trained model please)

  - name: MemoizationPolicy
  - name: TEDPolicy
    max_history: 5
    epochs: 100
  - name: RulePolicy
    nlu_threshold: 0.4
    core_threshold: 0.4
    fallback_action_name: "action_default_fallback"

In your pdf page 4 you will see the yellow errors that is because your polices is not matching with the current version of rasa that why I asked what is your current version if its 2.x then please update as shown above. Else, please provide more information for the same.

PS: Personally, I never worked on the Grakn KB, as it’s only helpful for the financial database, if you are planning you can use for general purpose like Q/A or FAQs then this will not be a helpful. If you need any further suggestions please feel free to discuss with me. Thanks.

I hope this will help you.

1 Like

@nik202 Thanks a lot …!

some queries are working :smile:

@carltondaniel Nice congratulations! Can I request to please close this thread as a solution for your reference and for other?

@nik202 Sure Thanks…!

@carltondaniel Thanks please close this thread choose the solution and tick it. Good Luck!

1 Like