Pip install rasa problem

Hello everyone,

I got this error when executing pip install rasa:

Collecting rasa
  Using cached rasa-1.10.2-py3-none-any.whl (510 kB)
Collecting PyJWT<1.8,>=1.7 (from rasa)
  Using cached PyJWT-1.7.1-py2.py3-none-any.whl (18 kB)
Collecting SQLAlchemy<1.4.0,>=1.3.3 (from rasa)
  Using cached SQLAlchemy-1.3.24.tar.gz (6.4 MB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... done
  Preparing metadata (pyproject.toml) ... done
Collecting absl-py<0.10,>=0.9 (from rasa)
  Using cached absl-py-0.9.0.tar.gz (104 kB)
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  error: subprocess-exited-with-error

  × Getting requirements to build wheel did not run successfully.
  │ exit code: 1
  ╰─> [20 lines of output]
      Traceback (most recent call last):
        File "C:\Users\taner\Desktop\rasa_chatbot\myenv\Lib\site-packages\pip\_vendor\pyproject_hooks\_in_process\_in_process.py", line 353, in <module>
          main()
        File "C:\Users\taner\Desktop\rasa_chatbot\myenv\Lib\site-packages\pip\_vendor\pyproject_hooks\_in_process\_in_process.py", line 335, in main
          json_out['return_val'] = hook(**hook_input['kwargs'])
                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        File "C:\Users\taner\Desktop\rasa_chatbot\myenv\Lib\site-packages\pip\_vendor\pyproject_hooks\_in_process\_in_process.py", line 118, in get_requires_for_build_wheel
          return hook(config_settings)
                 ^^^^^^^^^^^^^^^^^^^^^
        File "C:\Users\taner\AppData\Local\Temp\pip-build-env-1i0m0oot\overlay\Lib\site-packages\setuptools\build_meta.py", line 325, in get_requires_for_build_wheel
          return self._get_build_requires(config_settings, requirements=['wheel'])
                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        File "C:\Users\taner\AppData\Local\Temp\pip-build-env-1i0m0oot\overlay\Lib\site-packages\setuptools\build_meta.py", line 295, in _get_build_requires
          self.run_setup()
        File "C:\Users\taner\AppData\Local\Temp\pip-build-env-1i0m0oot\overlay\Lib\site-packages\setuptools\build_meta.py", line 480, in run_setup
          super(_BuildMetaLegacyBackend, self).run_setup(setup_script=setup_script)
        File "C:\Users\taner\AppData\Local\Temp\pip-build-env-1i0m0oot\overlay\Lib\site-packages\setuptools\build_meta.py", line 311, in run_setup
          exec(code, locals())
        File "<string>", line 34, in <module>
      RuntimeError: Python version 2.7 or 3.4+ is required.
      [end of output]

  note: This error originates from a subprocess, and is likely not a problem with pip.
error: subprocess-exited-with-error

× Getting requirements to build wheel did not run successfully.
│ exit code: 1
╰─> See above for output.

note: This error originates from a subprocess, and is likely not a problem with pip.

How can I fix this? Can you help me, please?

1 Like

Welcome to the forum :slight_smile:

As the error states, you don’t have the correct Python version.

On top of that, the docs state the following:

Currently, rasa supports the following Python versions: 3.7 , 3.8 , 3.9 and 3.10 . Note that Python 3.10 is only supported for versions 3.4.x and upwards. Additionally, rasa installation on Apple Silicon with Python 3.10 is not functional in 3.4.x but will be supported starting from 3.5.x .

Execute python -V to check what version you have.

1 Like