Pip index for rasa open-source installation

HI, I’m trying to install rasa open-source (v 2.8.13) using pip. It throws the below error:

Looking in indexes: https://pypi.org/simple, https://pypi.org/simple
ERROR: Could not find a version that satisfies the requirement rasa==2.8.13 (from versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1, 0.2.0a2, 0.2.0a3, 0.14.0a5, 0.14.0a6, 0.14.0a7, 0.14.0a8, 0.14.0a9, 0.15.0a6, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5, 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0rc4, 1.0.0rc5, 1.0.0rc6, 1.0.0rc7, 1.0.0rc8, 1.0.0rc9, 1.0.0rc10, 1.0.0rc11, 1.0.0rc12, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.2.0a2, 1.2.0a3, 1.2.0a4, 1.2.0a5, 1.2.0a6, 1.2.0a7, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 1.2.10, 1.2.11, 1.2.12, 1.3.0a1, 1.3.0a2, 1.3.0, 1.3.1a1, 1.3.1a3, 1.3.1a4, 1.3.1a5, 1.3.1a8, 1.3.1a10, 1.3.1a11, 1.3.1a12, 1.3.1a14, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.3.10, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.6.0a1, 1.6.0a2, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.10.0a1, 1.10.0a2, 1.10.0, 1.10.1, 1.10.2)

Can someone please help me with this? I don’t understand why versions > 1 are not listed. Am I on the right index? I’m on pip version 21.1.1. I’m also attaching the requirement.txt file requirements.txt (29 Bytes)

@nik202 any inputs here?

@lis did you tried pip install rasa==2.8.13 ?

@nik202 Im doing a pip install -r requirements.txt

@lis why? if you want to upgrade?

i want to freeze it with this version. is it a bad practice?

@lis I never upgrade by this process if I already have the previous version of rasa, so I’d recommend just stick on the basic upgrade using pip install rasa and rest installation will take care of all the required packages and version.

Umm, bchanging the rasa version in the requirements.txt would still work in that case right?

@lis we normally used the requirements.txt file for specific package installations, but you can use it but I will not recommend for the same.

@nik202 I need this for futue also. I don’t want to run pip install for every package.

But is that the problem? However I run,the pypi index-url will be the same right? I dont understand why it’s not able to find this particular version of rasa

@lis Rasa Open Source Change Log

You need to install every time, which is recommended as every version have their own packages and their versions requirements. You every time cannot use the requiremets.txt whilst only changing the rasa versions will not gonna help sorry.

You only need to install or upgrade to the latest version whilst using pip install rasa or simply using pip install rasa (for latest) and every related package will be installed by itself, except the one which you have used for custom actions such as pandas, NumPy, etc etc for running your code for that you need to install the same or if you have environment it can deal that.

I hope this will give you a clear idea about the same. good luck

This happens when your Python version is not compatible.

As per the docs, your Python version should be 3.7 or 3.8.

You can verify your Pip’s Python version with pip -V:

pip 21.3.1 from C:\Users\Chris\AppData\Roaming\Python\Python38\site-packages\pip (python 3.8)

(Python version written at the end)

@ChrisRahme you’re right. python version is 3.9 for me. thanks!

1 Like

@ChrisRahme I’m trying to install rasa 2.8.13 and I’m running into this error now:

ERROR: Could not find a version that satisfies the requirement tensorflow<2.7,>=2.6 (from rasa) (from versions: none)
ERROR: No matching distribution found for tensorflow<2.7,>=2.6

@lis please install pip install tensorflow==2.6 and then rasa version

Do update me please.

ERROR: Could not find a version that satisfies the requirement tensorflow==2.6 (from versions: none)
ERROR: No matching distribution found for tensorflow==2.6

@lis I yesterday only install that distribution in my machine.

Please show me the output of pip -V (inside your virtual environment if you have one).

You may have installed Python for 32-bit systems, or even worse, your system is itself 32-bits.

According to the TensorFlow docs:

TensorFlow is tested and supported on the following 64-bit systems:

  • Python 3.7–3.9
  • Ubuntu 16.04 or later
  • Windows 7 or later (with C++ redistributable)
  • macOS 10.12.6 (Sierra) or later (no GPU support)

pip 21.1.1 @ChrisRahme

Full output please