Permision denied when using REI script and Rasactl to deploy Rasa X

Hi, I am a new user of Rasa and I am trying to deploy a Rasa X server.

I install kubectl, kind, helm by myself using the guide on their home page. Then I run:

curl -O && bash -y

and then:

rasactl start --project --values-file values.yml

(my project is just a rasa init project)

Here is my values file:

  tag: "1.1.0"
    username: "admin"
    password: "some-password"
  passwordSalt: "some-password"
  token: "some-password"
  jwtSecret: "some-password"

  tag: "1.1.0"
  tag: "1.1.0"
  tag: "3.1.0-full"
      enabled: true
      enabled: true
  token: "some-password"
    password: "some-password"
    postgresqlPassword: "some-password"
    password: "some-password"

Then I use rasactl connect rasa.

After that, when I train new model, it is saved successfully new model to models in my project folder. Hower, when I try to add new NLU data in Rasa X interface, there is nothing happen in nlu.yml file.

And if I stop and start rasactl namespace again, my new adding NLU data is gone.

Here is the log of rasa x: request to external service: telemetry key not set. request to external service: telemetry key not set.
Job "DumpService.dump_changes (trigger: date[2022-05-16 10:45:16 UTC], next run at: 2022-05-16 10:45:16 UTC)" raised an exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/dist-packages/apscheduler/executors/", line 125, in run_job
    retval = job.func(*job.args, **job.kwargs)
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/services/", line 94, in dump_changes
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/services/", line 116, in _dump_changes
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/services/", line 140, in _dump_domain
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/services/", line 368, in dump_domain
    io_utils.write_file(domain.filename, domain_yaml)
  File "/usr/local/lib/python3.8/dist-packages/rasax/community/utils/", line 160, in write_file
    with open(file_path, mode, encoding=encoding if "b" not in mode else None) as file:
PermissionError: [Errno 13] Permission denied: '/app/local_project/domain.yml'

I searched Google and tried to log in to rasa docker container but I can not find the “/app” folder.

Can anyone please tell me the way to solve this problem?

Thank you so much!

Update: Seem that I was able to solve the problem by run the command: sudo chmod -R 777 my_project_folder

After running this command, Rasa X is able to save new data to my project nlu.yml.

But that mean, by default, rasactl does not use use Root to mount $(pwd) to app folder in container, right?