Not working: Rasa X Integrated Version Control

I can’t make Rasa X Integrated Version Control work.

Before starting my own development I wanted to deploy the code from “rasa init” to Rasa X on AWS:

I actually tried both “Quick installation” and Docker Compose with multiple AWS AMIs. After connecting my GitHub repository I get the same result every time:

  • I click the “Train” button, but get “Training failed”
  • Maybe Rasa X is not pulling everything from the GitHub repository? E.g. I can see all the responses in Rasa X, but no stories
  • Under Training -> Domain it says: “7 inconsistencies were detected with this file. The intent deny was found in the domain but is missing in the training data…”
  • When I make changes on Rasa X e.g. delete an intent or rename a response and press “Add changes to Git server”, a PR is created on GitHub, but without any changes “0 changed files with 0 additions and 0 deletion.”

Other questions:

  • Is it correct to add the models directory to .gitignore and train on Rasa X?

Hi @MartinJaskulla,

Yes, it’s correct to ignore the models directory.

I don’t know that this is a IVC issue or another issue - if you run rasa data validate locally, on rasa 1.10.14, does it pass? Did you do rasa init using a compatible version of rasa? On your deployment, what is the output of the following after you attempt training?

sudo docker-compose logs rasa-x
sudo docker-compose logs rasa-worker

Local machine

  • rasa data validate

rasa.validator - No story structure conflicts found.

  • rasa version

Rasa Version : 2.0.0 Rasa SDK Version : 2.0.0 Rasa X Version : None Python Version : 3.7.7 (default, Jun 22 2020, 16:20:58) Operating System : Darwin-19.6.0-x86_64-i386-64bit Python Path : /Users/martin.jaskulla/.pyenv/versions/3.7.7/bin/python3.7


sudo docker-compose logs rasa-x

sudo docker-compose logs rasa-worker