Not able to launch rasa x after training initial model

Hi all

I am trying to create a chat-bot and I started with the basics.

I created a virtual python env and then did rasa init to initialize and pre train a model. I tried to connect to rasa x using the command rasa x. But it failed with the error(listed below). I even tried to fork existing examples for the bots and keep reaching the same error. I couldn’t find anything related to it in the forum.

Here is the error output.

Starting Rasa X in local mode… :rocket: Traceback (most recent call last): File “/Users/username/bot_try/venv/lib/python3.7/site-packages/rasa/cli/x.py”, line 473, in run_locally args, project_path, args.data, token=rasa_x_token, config_path=config_path File “/Users/username/bot_try/venv/lib/python3.7/site-packages/rasax/community/local.py”, line 233, in main _start_event_service() File “/Users/username/bot_try/venv/lib/python3.7/site-packages/rasax/community/local.py”, line 139, in _start_event_service fn=_event_service, args=(LOCAL_ENDPOINTS_PATH,), daemon=True File “/Users/username/bot_try/venv/lib/python3.7/site-packages/rasax/community/utils/common.py”, line 855, in run_in_process p.start() File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/process.py”, line 112, in start self._popen = self._Popen(self) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/context.py”, line 284, in _Popen return Popen(process_obj) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/popen_spawn_posix.py”, line 32, in init super().init(process_obj) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/popen_fork.py”, line 20, in init self._launch(process_obj) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/popen_spawn_posix.py”, line 47, in _launch reduction.dump(process_obj, fp) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/reduction.py”, line 60, in dump ForkingPickler(file, protocol).dump(obj) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/connection.py”, line 957, in reduce_connection df = reduction.DupFd(conn.fileno()) File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/connection.py”, line 170, in fileno self._check_closed() File “/Users/username/.pyenv/versions/3.7.0/lib/python3.7/multiprocessing/connection.py”, line 136, in _check_closed raise OSError(“handle is closed”) OSError: handle is closed

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up. If you need help fixing the issue visit our forum: https://forum.rasa.com/. /Users/username/bot_try/venv/lib/python3.7/site-packages/rasa/core/run.py:312: FutureWarning: The method 'EventBroker.close was changed to be asynchronous. Please adapt your custom event broker accordingly. Support for synchronous implementations will be removed in Rasa Open Source 2.2.0. (will be removed in 3.0.0) f"The method '{EventBroker.name}.{EventBroker.close.name} was " /Users/username/bot_try/venv/lib/python3.7/site-packages/rasa/core/run.py:317: RuntimeWarning: coroutine ‘EventBroker.close’ was never awaited

1 Like