Rasa x can not start

Hi guys, anyone seen this issue?

Thank you

(rasa) strelnikov@103109817 rasa-bot % rasa x
Starting Rasa X in local mode… :rocket: 2021-03-07 21:55:58 WARNING rasax.community.services.insights.insight_service - No local evaluation result files found. Traceback (most recent call last): File “/Users/strelnikov/.pyenv/versions/3.8.7/envs/rasa/lib/python3.8/site-packages/rasa/cli/x.py”, line 494, in run_locally local.main( File “/Users/strelnikov/.pyenv/versions/3.8.7/envs/rasa/lib/python3.8/site-packages/rasax/community/local.py”, line 250, in main _start_event_service() File “/Users/strelnikov/.pyenv/versions/3.8.7/envs/rasa/lib/python3.8/site-packages/rasax/community/local.py”, line 140, in _start_event_service common_utils.run_in_process( File “/Users/strelnikov/.pyenv/versions/3.8.7/envs/rasa/lib/python3.8/site-packages/rasax/community/utils/common.py”, line 882, in run_in_process p.start() File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/process.py”, line 121, in start self._popen = self._Popen(self) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/context.py”, line 284, in _Popen return Popen(process_obj) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/popen_spawn_posix.py”, line 32, in init super().init(process_obj) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/popen_fork.py”, line 19, in init self._launch(process_obj) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/popen_spawn_posix.py”, line 47, in _launch reduction.dump(process_obj, fp) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/reduction.py”, line 60, in dump ForkingPickler(file, protocol).dump(obj) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/connection.py”, line 968, in reduce_connection df = reduction.DupFd(conn.fileno()) File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/connection.py”, line 170, in fileno self._check_closed() File “/Users/strelnikov/.pyenv/versions/3.8.7/lib/python3.8/multiprocessing/connection.py”, line 136, in _check_closed raise OSError(“handle is closed”) OSError: handle is closed

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up. If you need help fixing the issue visit our forum: https://forum.rasa.com/. (rasa) strelnikov@103109817 rasa-bot % rasa --version Rasa Version : 2.3.4 Rasa SDK Version : 2.3.1 Rasa X Version : 0.37.1 Python Version : 3.8.7 Operating System : macOS-10.15.7-x86_64-i386-64bit Python Path : /Users/strelnikov/.pyenv/versions/3.8.7/envs/rasa/bin/python3.8

1 Like

Hey @strelnikov, it’s this issue and a colleague is working on fixing it :slightly_smiling_face:

Is it fixed?

@Prakhar333 if you look at the linked Github issue, it was marked as done in March, meaning that the fix should already be in the handful of releases made since then :wink:

Hi @SamS ,

The linked github issue doesn’t exist, could you post the link again?

@batman sorry, I now realised that the issue lives in a private repo and so it can’t be viewed by everyone… My bad. In any case, on the issue basically says that it was fixed around March 18. Which means that if you’re having trouble with a version of Rasa X that was released after that date, it’s something else and should be reported in a new thread/issue :slightly_smiling_face:

hi @SamS

I’ve installed Rasa and the current Rasa X using Anaconda on Win10. I’m receiving this error below. I’d love some help – how do i fix this ?? :frowning:

Error when trying to start Rasa X (in local mode, on Anaconda): Starting Rasa X in local mode… :rocket: 2021-06-29 23:22:09 WARNING rasax.community.services.insights.insight_service - No local evaluation result files found. 2021-06-29 23:22:11 ERROR concurrent.futures - exception calling callback for <Future at 0x148c2c93d00 state=finished raised gaierror>

Any ideas?

Hey @hgoona, I believe this is a different issue than the one mentioned above. Therefore, could you create a new thread, please?

1 Like

I am having the same issue. Is there any solution ?

Hi @SamS I am having the same error as mentioned above. Rasa Version : 2.7.1 Minimum Compatible Version: 2.6.0 Rasa SDK Version : 2.7.0 Rasa X Version : 0.41.1 Python Version : 3.8.0 Operating System : Windows-10-10.0.16299-SP0 Python Path : c:\program files\python38\python.exe

This is the version of rasa and rasa x. Can you provide any solution to fix this?

@devashree_09 are you seeing the exact same error as in the original post? That one should be fixed now… If you mean the error mentioned by @hgoona, then I’ll say what I said to them: To create a new thread for it (unless @hgoona you’ve already created one).

No but same as @strelnikov

Hi @SamS I have created a new thread. For my problem

1 Like