No matching distribution found for tensorflow==2.1.0

Hello can u help me please Im trying to install Rasa starterpack and I got this error No matching distribution found for tensorflow==2.1.0 Can anyone please help me

hey @boutaina, try installing using below command:

pip3 install --upgrade tensorflow rasa

what is the version of pip and python that you are using?

Hi @boutaina,

besides the questions @JiteshGaikwad already asked, which OS are you using?

Kind regards

(rasabot) C:\Users\Dell\Desktop\WeatherBot>pip3 install --upgrade tensorflow rasa ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none) ERROR: No matching distribution found for tensorflow

Hey @VinayKumarNC2019, what is the version of python and pip are you using and also the OS?

Hi Jitesh, Thanks for checking, issue resolved after using Python 3.6.5. I am really not sure why RASA has not provided this information in the installation step as using latest version of Python or 3.6.0 both doesn’t work. Do you have any pointers like Videos or documents to build models with latest Rasa? most of the videos in YOU TUBE seems to be already out dated.

Hey @VinayKumarNC2019,

They have provided the python version that needs to be used in the docs:

Check out this playlist by @koaning, he has explained well about the latest NLU model.

(Edit: Sorry I forgot to paste the link😅)

I hope this helps :blush:

Indeed! We’re making multiple youtube playlists that contain explainers of the algorithms that we have. Feel free to ping me on topics that you’d love to see.

1 Like

it works! 666

rasa==1.10.1 requires tensorflow==2.1.0 requires python v3.7 (not v3.8)

This is what fixed it for me

brew install python@3.7
brew link python@3.7 --force --overwrite 
pip list | awk1 | xargs -L1 -t pip install --user --force-reinstall --ignore-installed --no-binary :all: 
pip3 install --upgrade tensorflow rasa
1 Like

Thanks! It worked