No matching distribution found for tensorflow==1.12.0

(Neel) #1

Hallo,

Unable to install tensorflow pipeline " Could not find a version that satisfies the requirement tensorflow==1.12.0 (from -r alt_requirements/requirements_tensorflow_sklearn.txt (line 4)) (from versions: 1.13.0rc1)

No matching distribution found for tensorflow==1.12.0 (from -r alt_requirements/requirements_tensorflow_sklearn.txt (line 4)) "

command: pip3.7 install -r alt_requirements/requirements_full.txt

MacOS - High Sierra Python 3.7.2

Am i missing out something?

Regards, Neel

0 Likes

(Dario Fiore) #2

I have the same issue. pip in anaconda provides tensorflow 1.13.0rc1 and does not deliver 1.12.0. Removing the version 1.12.0 in the requirements.txt worked for me. But I am not really happy with that.

0 Likes

(Nandhini A) #3

Hi, Is this change giving an error with tensorflow when using bot?

0 Likes

(Ella Rohm-Ensing) #4

Hey @numpy035 and likely @dariofiore, looks like you’re trying to run Rasa Core on python 3.7, which is not currently supported. 3.7 support should be coming soon, but in the meantime I would recommend creating a virtual environment with python 3.6 for your Rasa project.

2 Likes

(Imandi Siva Lakshmi Narayana) #5

hi @erohmensing I have tried using python 3.6.8 with the virtual environment yet still getting the same error " no matching distribution found for tensorflow = = 1.12.0". Is there any other way to sort out this issue?

0 Likes

(Ella Rohm-Ensing) #6

@islnarayana do you still get this error if you just pip install tensorflow==1.12.0 ? Could you post a stack trace for where your error is coming from please?

0 Likes

(Imandi Siva Lakshmi Narayana) #7

@erohmensing thanks for your prompt reply, issue got resolved. Error occurred because of versions mismatch in dependent packages of tensorflow-1.12.0.

For installing tensorflow-1.12.0 in windows laptop(without internet connection, downloaded packages from pypi.org website) I have used below versions and successfully installed Tensorflow.

Python version used : 3.6.1 Dependent packages: astor-0.7.1-py2.py3-none-any.whl termcolor-1.1.0.tar.gz Keras_Applications-1.0.7-py2.py3-none-any.whl absl-py-0.7.0.tar.gz numpy-1.13.3-cp36-none-win_amd64.whl protobuf-3.6.1-cp36-cp36m-win_amd64.whl Keras_Preprocessing-1.0.9-py2.py3-none-any.whl Keras_Preprocessing-1.0.9-py2.py3-none-any.whl Markdown-2.6.8.tar.gz tensorboard-1.12.2-py3-none-any.whl grpcio-1.18.0-cp36-cp36m-win_amd64.whl gast-0.2.2.tar.gz tensorflow-1.12.0-cp36-cp36m-win_amd64.whl

0 Likes

(Ella Rohm-Ensing) #8

@islnarayana great! Glad you got it resolved. And thanks for posting your versions to help out others :slight_smile:

0 Likes