Newly-created responses do not display in Rasa X UI

In the Rasa X UI, when I create a new utterance (e.g. utter_legal_disambiguate) it is not available for me to select in “Talk To Your Bot: Interactive Learning”. I’ve struggled with this for several hours and just can’t figure out what I’m doing wrong.

In this screenshot, you can see the new responses I’ve added

In this screenshot, you can see the available responses in interactive training. None of my new responses are available.

To troubleshoot, I’ve tried the following:

  • Reload browser
  • Start and stop rasa x server
  • Train and publish new model
  • Edit domain.yml directly
  • Manually add stories

The last 2 steps – editing domain.yml and manually adding stories – seems to have some effect – sometimes, some of my new potential utterances will appear. But not all of them, and I can’t establish a pattern as to when or why this happens.

Any suggestions?

NB. I’m completely new to Rasa, but very experienced with LUIS.

1 Like

I was facing the same problem. Here is what worked for me.

  1. Make sure newly added utters are added under actions: in domain.yml
  2. Retrain the model from cli. rasa train
  3. Restart rasa x
1 Like

Thanks @jabeevulla. This issue is now listed as a bug in Github: Rasa X domain file not updated · Issue #3610 · RasaHQ/rasa · GitHub

Hey @intranetchris. I added this same update to GitHub that you might have seen already but want to add the same comment here in case someone only sees this thread. You can now edit the domain in the UI in the latest version of Rasa X: Release 0.19.1. You should upgrade to this new version!