My rasa stories are mapped to wrong actions

image This is my

My story goes to the second intent after reaching the affirm step (5th step). I have been trying to identify what is wrong but am not able to do so. Kindly help !! @akelad

what do you mean goes to the second intent? Could you provide some debug logs from your conversation?

I mean to say that after the “affirm_this” the chatbot goes again to the “utter_which_project” step . Even if I replace the the actions after “affirm_this” with any other normal utter step like “utter_bye” , it still goes back the “utter_which_project” step of the story. I will send the log files.

@akelad : This is how I have tried to use interactive learning to make my bot follow the same steps as my story, but somehow after the fifth step it doesn’t follow the order even after I have used interactive learning to train my model.

I am not able to understand why ‘entity_NORP’ is being given although I have not defined it anywhere. Hence I am not able to understand the logs.

Would be kind if you could suggest something on this

@laks6032 it looks like the confidence of your NLU is super low, so i presume sometimes intents are classified wrong. As for the entities, seems like maybe something extracted by spacy.

Can you maybe share your training data and the config?

@akelad Hey there… I am attaching the config file image

I have a lot of intents in my training data hence not sure of how much I should be attaching here so I am only attaching the data for the concerned intents image image

Please do help…I have been stuck with this issue for the past 2 weeks, have tried almost anything and everything given by people in the community forum but of no use till now.

do you also have the word okay in other intents? If you have a lot of intents and little training data then mispredictions are more likely. Also I just noticed in your logs the action execution fails - did you configure an endpoint for that?