Ted policy predicting wrong action

hi i keep getting bugs when running my chatbot. once i retrain it with the same data (i just delete the latest model so it can be retrained with no changes), it gives the same error but with different intents

in my stories for example i write:

  • story: acad path steps:
    • intent: academics
    • action: utter_affirm
    • action: utter_sub_category

and when i run it: rasa run --debug:

2021-08-04 09:04:37 DEBUG rasa.core.processor - Received user message ‘/academics’ with intent ‘{‘name’: ‘academics’, ‘confidence’: 1.0}’ and entities ‘[]’

2021-08-04 09:09:48 DEBUG rasa.core.policies.ted_policy - TED predicted ‘utter_im_upbot’ based on user intent.

it predicts a different action. when i retrain it gives wrong action but sometimes with other intents

@ccloud It’s hard to debug the problem with access to only one story. Are there any other stories where utter_im_upbot is the next action after intent academics?

i am also getting the same type i checked my file i have only use that intent once and performing an action and ted doesn’t perform the utter_action i choose it perform action_listen and when i manualy type the payload of the button it is working i check in debug mode it map right intent but performing wrong action @dakshvar22