Multiple Rasa X on single Ubuntu Server

Is it possible to run multiple instances of Rasa X on a single Ubuntu Server? Right now I have set up two rasa x folder on the server. While I run “docker-compose up -d” on one folder everything runs fine. But when I run “docker-compose up -d” on the second folder Nginx docker gives an error of port 80 is already in use. Any help or explanation will be helpfull for me.

You can update by writing docker-compose.override.yml file and exposing second bot to different port. Meanwhile does your both the bots are in /etc/rasa folder?

1 Like

Okay Thanks. I have done that. Now both are working fine. No both are not in /etc/rasa folder. I have installed the second one on different folder.

Hi, I am trying the same, can you share your docker-compose.override.yml

Hi @vanshkapil, Here is your required change that I have done to support multiple instances. I am sharing only a screenshot of the change that needs to be done. Rest you will understand the concept. Screenshot from 2020-12-18 11-32-24

Thanks. This is helpful. 1 more question, with 1 instance, we just use the url to access rasa-x. How would we access the second instance now ?

For the second instance, you have to install rasa-x on another directory. And you just need to change the ports in its Nginx configuration. I am currently running 4 rasa-x on the same ubuntu server.

1 Like

INstallation is ok and docker-compose settings are also clear. What I am asking is, in case of only 1 RASA-X instance, I can reach it by accessing URL on the browser. But for multiple instances, how will my URL change to reach different instances.

Oh, now I understand your problem. For 1st Instance use this URL: http://127.0.0.1:82

For 2nd Instance use this URL: http://127.0.0.1:84

As defined in nginx configuration.

If still there is any confusion you can ask me again. I will help you.

You can access multiple rasa-x instance from url by changing the port number ahead of the address as described above.

You will get the port number from docker compose nginx ports.

1 Like

docker-compose.override.yml of instance 1 image

docker-compose.override.yml of instance 2 image

Instance 1 starts up without any trouble. But when I start instance 2 , I get this error

Hmmm. Is there any service running that is using port 443? Like “apache2” ??