Multiple domain file

Hi have following structure: project_dir

actions (directory) data (directory) models domains (directory) - intents.yml - actions.yml - responses.yml - slots.yml - entities.yml - forms.yml - general.yml

  • config.yml
  • credentials.yml
  • endpoints.yml

I am running following command to execute multiple domain file rasa train --domain /domains (I have also tried rasa train --domain .\domains)

But it is not working. What is right way to execute this command to work with multiple domains file?


Yes, splitting the domain is a bit harder than the rest.

@jonathanpwheat built this script to merge multiple domain files into one: Rasa domain Assembler · GitHub

You can change your virtual environment activation file to create a command that executes this script before training the bot.

1 Like

Try simply -

rasa train --domain domains

There’s no need for the / or ./

Actually it’s hard to tell what your structure is. Can you try to list it again with some indenting? Treat it like a code block if you need to or indent the lines with periods.

I only say this because you may need to have --domain data/domains if your domains is a subdirectory of data.

The script that Chris mentioned is for Rasa 1.x .

Rasa 2.x allows for the breaking up of domain, nlu and story data.

You can read about how to do this in more detail here - Organize your Rasa 2.0 training data like a boss - DEV Community

1 Like

I want to add that even though rasa train --domain domains works well, Rasa X has been having trouble dealing with multiple domain files and not detecting them (tried locally and on a server).

I don’t know if this is a common issue or if it only happens with me for some reason. This is why I’d personally rather use the script.

Oh yea, there is that.
We don’t use RasaX so I always forget that, thanks.

1 Like