Issue connecting to channels on Rasax EE deployed using Helm chart on GKE

Hi I have installed RasaX on GKE using Helm chart tag: 1.8.1

Here is the instance of our RasaX:

The chatbot works as expected, but I need help with setting up channels (Telegram, Facebook, Slack). I have setup a Telegram bot using Botfather and followed the steps as mentioned here to setup the channel:

I setup connector in the values.yaml file like mentioned here for telegram channel:

I am not receiving any response from the bot when I interact using the telegram bot. I don’t see anything in the logs that suggest the requests are actually hitting the webhook. Following is the webhook_url that I think is the issue:

When I hit the above URL, it takes me directly to the login page. Seems like there an issue with either deployment/installation or if I am missing any steps to expose webhooks. Could also be that I have configured something wrong with my ingress.

The chatbot I have so far is a very simple one with hard coded responses for user inputs like (1,2 and so on). So, I don’t have any custom actions setup currently. I am attaching the values.yaml file I have so far by masking any secrets.

Following is what I did differently than the steps provided in the documentation :

  • I installed a separate instance of nginx-ingress using the stable/nginx-ingress helm chart as I was having issues with setting up ingress with the default rasa/nginx chart and configuring SSL using letsencrypt.

I am attaching the ingress file I am using right now and the values.yaml for RasaX EE Helm chart. Any help is greatly appreciated. The chatbot we have is for information related to Covid-19, so it is a bit time sensitive for us to get to the users.

Thanks, Shashi

values.yml (2.2 KB) rasax-ingress.yml (885 Bytes)

Hi @deshetti, which version are you running? Previously, you had to change the webhook to to route the request to rasa-production. As of 0.27, should work fine.

This is of course however with the regular nginx, where that /core/ rerouting is configured – does your ingress still route requests through the rasa/nginx container?

Sorry i’m dumb, of course that is in the values file :grinning_face_with_smiling_eyes: as long as our nginx rerouting is still there under the hood, the first URL i posted should hopefully work.

The info is at the bottom of the page here: