Installing Rasa Starter Pack

Hello , Would you please help me install Rasa StarterPack , I actually used this method to add a new component but I always have this error “” Calling rasa.nlu.train directly is no longer supported " I reaaally need some help

Hi @boutaina,

Are you using the Python API? It’s recommended to train NLU models using the command line interface.

Otherwise you will have to use the NLU training functions in rasa.train

Thank you for the reply it worked but I still have an issue which is RASA can’t find the new component I just added although I mentionned it in the pipeline and the .

Hi @boutaina,

Glad to hear it worked. As for the other issue, adding the component to the registry is not the recommended way of doing this. I recommend reading Juste’s article here for helping with setting up custom components. Let me know if that approach doesn’t work

Yeess thank you so much for your help !! It actually worked but I still have another problem would you please help me with the data . I want to train my NLU model with json files in the data folder but When I try tthis command ("rasa train nlu ") it says “No NLU data given” . I don’t know what I did wrong , is it the format ?