Installing Rasa on M1 Pro (Macbook Pro 14")

Ive been trying to install rasa on my mac with M1 Pro processor. ive tried this but its not working. different instances of installations gave me different types of error. has anyone here installed rasa on a MacBook with M1 Pro processor

Hi! I’m using M1 Pro too and the steps working fine for me for rasa 2.8.x and rasa 3.0.x

If you want to install rasa 3.1, you can use this env configs. It’s working fine too.

I tried this and its not working. whats the IDE you’re using This is the error Im getting

Traceback (most recent call last):
  File "/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/", line 87, in _run_code
    exec(code, run_globals)
  File "/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/site-packages/rasa/", line 14, in <module>
    from rasa.cli import (
  File "/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/site-packages/rasa/cli/", line 9, in <module>
    import rasa.core.utils
  File "/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/site-packages/rasa/core/", line 25, in <module>
    from sanic.views import CompositionView
ImportError: cannot import name 'CompositionView' from 'sanic.views' (/Users/kalpafernando/miniforge3/envs/formbot/lib/python3.8/site-packages/sanic/

I just use terminal and fallow An Unofficial Guide to Installing Rasa on an M1 Macbook steps

conda env create -v --name rasa3-1 -f env_rasa3-1.yml
conda activate rasa3-1

pip install git+ --no-deps
pip install git+ --no-deps
pip install git+ --no-deps

My env.yml file

env_rasa3-1.yml (4.0 KB)

It worked. Thank you so much

Following error occurs when i’m trying to run

rasa run actions

How to fix this

I face the same issue

update rasa sdk to version 3.1.1 or 3.2.0

pip install git+ --no-deps


pip install git+ --no-deps