Installing Rasa Demo


I’ve cloned Rasa demo Sara bot and ran pip install -e .

At this point make train-nlu fails because tensorflow is not installed I have tried pip install tensorflow Then saw a forum question with a similar problem so ran pip install -r requirements.txt

Still fails.

Tried the same thing using pip3 (still cannot work out which one I’m supposed to use), still no joy

here is the error, towards the top it states successfully installed tensorflow, then at the end says please install tensorflow.

How do I get this working?

Successfully installed absl-py-0.6.1 astor-0.7.1 backports.weakref-1.0.post1 enum34-1.1.6 funcsigs-1.0.2 futures-3.2.0 gast-0.2.0 grpcio-1.17.1 h5py-2.8.0 keras-applications-1.0.6 keras-preprocessing-1.0.5 markdown-3.0.1 mock-2.0.0 numpy-1.15.4 pbr-5.1.1 protobuf-3.6.1 setuptools-40.6.3 six-1.12.0 tensorboard-1.12.1 tensorflow-1.12.0 termcolor-1.1.0 werkzeug-0.14.1 wheel-0.32.3 (rasa_multi) dave@yoga-ubuntu:~/chatbots/rasa-demo$ make train-nlu python3 -m rasa_nlu.train -c nlu_tensorflow.yml --fixed_model_name current --data data/nlu/ -o models --project nlu --verbose Traceback (most recent call last): File “/usr/lib/python3.6/”, line 193, in _run_module_as_main “main”, mod_spec) File “/usr/lib/python3.6/”, line 85, in _run_code exec(code, run_globals) File “/home/dave/.local/lib/python3.6/site-packages/rasa_nlu/”, line 184, in num_threads=cmdline_args.num_threads) File “/home/dave/.local/lib/python3.6/site-packages/rasa_nlu/”, line 148, in do_train trainer = Trainer(cfg, component_builder) File “/home/dave/.local/lib/python3.6/site-packages/rasa_nlu/”, line 152, in init components.validate_requirements(cfg.component_names) File “/home/dave/.local/lib/python3.6/site-packages/rasa_nlu/”, line 63, in validate_requirements “Please install {}”.format(", ".join(failed_imports))) Exception: Not all required packages are installed. To use this pipeline, you need to install the missing dependencies. Please install tensorflow Makefile:19: recipe for target ‘train-nlu’ failed make: *** [train-nlu] Error 1

I think the answer is in creating the virtual environment.

I created a new one, but used venv from python 3 instead of virtualenv.

python3 -m venv rasa-demo-py3

source ~/python_envs/rasa-demo-py3/bin/activate

pip install -r requirements.txt

Not needed, as it installs tensorflow 12, and is not described in the readme.

pip install -e .

This uninstalls tensorflow 12 and installs tensorflow 10

make train-nlu

now works :slight_smile:

but make train-core fails with a memory error

Makefile:22 recipe for target 'train-core' failed
make: *** [train-core] Error 1

I am running this on a temporary dev server, Yoga laptop dual booting into Ubuntu 18.04 16Gb RAM 12Gb free disk space, is that not enough?

I banged my head against this one for a bit and have decided to take a step back.

It wasn’t initially obvious to me, but I believe this demo is really intended for developers running on linux, not windows. I was a bit baffled by the “make train-core” command, then realized that the makefile was a linux construct, and would need some finagling to work properly.

I tried downloading the recommended windows make tool, but it wasn’t working, so I just manually copied and pasted the python command inside the make file (changing some syntax). It seems to work.

For time being. Rasa NLU requires tensorflow==1.10.0 If you use newer version than that it is gonna raises the error Please install tensorflow

@DonHolloway How did you change the syntax in the python command for windows. Im stuck at exactly the same spot. :slight_smile: