Installed RasaX , unable to get /webhooks/rest/webhook


I am a bit confused on how RasaX works. Here are the steps I did

  1. installed RasaX (quick installation) ,
  2. uploaded my stories , nlu data , domain
  3. did Training

Everything is good at this point. Now when I proceed and send a POST request to

it does nothing.

If I remove port 5005 , it respond back with html response

Do I need to install Rasa also and run that by binding it to the models trained to be able to access webhooks/rest/webhook endpoint or is that all included in RasaX itself ?


You will also need pip install rasa

@talhashaikh5 thanks, I installed rasa , now I get into the etc/rasa/ folder where RasaX is installed and did command rasa run

its showing error as

ValueError: Error when trying to expand the environment variables in ‘${RASA_MODEL_SERVER}’. Please make sure to also set these environment variables: ‘[’${RASA_MODEL_SERVER}’]’

1 Like

try creating a virtual environment and install rasa and rasa x into it for example

first create a virtual environment

python3 -m venv venv

then activate it

source venv/bin/activate

now install rasa

pip install rasa 
pip install rasa-x --extra-index-url

@talhashaikh5, thanks I did the env and got it working. Just to make it clear to me so I not mess up :slight_smile:

I started rasax in docker as the quick installation says then I installed rasa and run it from my working directory , but referenced the models from the rasax folder

Is this is the way it should be working? thank you for your help!

@DeepakTiwari84 i am glad that i was helpfull to you. can you mark that as a solution ?

rasa x is the ui layer thats build on the top of rasa core.

Sure , so I am doing it correctly?

@DeepakTiwari84 may i know why you are running rasa x on docker ?

@talhashaikh5 I tried the manual here and was not able to set it up correctly on production

1 Like

I finally figured it out , rasa core is a part of Rasa X , so you do not need to install it if you already have Rasa X.

To query the model on say rest channel , you need to add rest in your credentials.yml file, so it look like this:

  url: ${RASA_X_HOST}/api


and then you can query your models on


The key part for me was adding /core after the Rasa X domain, thanks @DeepakTiwari84

@DeepakTiwari84 I am using local mode and trying to connect rasa server with my custom channel using RestInput. I did add /core to my postman request URL like this http://localhost:5005/core/webhooks/rest/webhook (Although currently i am testing it locally, I plan to shift to a domain) I still get the same error. Is it mandatory to run Rasa X server ? Currently i am running rasa server using command rasa run