Rasa x

installed rasa x on ubuntu using below pip command pip install rasa-x --extra-index-url https://pypi.rasa.com

it installed successfully however when I run below command

rasa init rasa x

it throws error - rasa command not found

please try running rasa init

tried rasa init as well

however no luck!

Please install rasa x with pip install rasa-x --extra-index-url https://pypi.rasa.com/simple.

1 Like

yep sorry about that guys – we just fixed this in our docs, but they’ll take a little bit to build :slight_smile:

Thank you so much! It worked!

Any idea, how to add new action from RasaX frontend? Entering new action in domain.yml in ‘actions’ section directly does not reflect in RasaX->Talk to your bot->Interactive Learing

Hi @prakashdale. You can now edit the domain in the UI in the latest version of Rasa X: Release 0.19.1 . You should upgrade to this new version!

What is the best way to upgrade as the installation and upgrade instructions are not picking up the new version. Thanks.

EDIT: running pip install -U rasa-x --extra-index-url https://pypi.rasa.com/simple worked just fine.

I had to add this to my PATH:


that’s where the rasa script is installed. But then I get

Traceback (most recent call last): File “/Users/Dennis/Library/Python/3.6/bin/rasa”, line 6, in from rasa.main import main File “/Users/Dennis/Library/Python/3.6/lib/python/site-packages/rasa/init.py”, line 8, in from rasa.run import run File “/Users/Dennis/Library/Python/3.6/lib/python/site-packages/rasa/run.py”, line 9, in from rasa.model import get_model File “/Users/Dennis/Library/Python/3.6/lib/python/site-packages/rasa/model.py”, line 10, in import rasa.utils.io File “/Users/Dennis/Library/Python/3.6/lib/python/site-packages/rasa/utils/io.py”, line 12, in import ruamel.yaml as yaml ModuleNotFoundError: No module named ‘ruamel.yaml’

Thank you very much

1 Like

hey this command giving me some dependencies error:

I have already installed the rasa x and deployed it on server, but when I hit (rasa --version) it shows (rasa : command not found)

How to create an image of rasa on docker compose? So that I can deploy multiple bot using same instance for multiple bot.