Installation issue

when i try to install the requirements i got this error

Command “python egg_info” failed with error code 1 in C:\Users\AARBOR~1\AppData\Local\Temp\pip-install-oc98jt05\neuralpy\

There are a few things that could cause this, but an important question is - which python version are you running?

My first guess is that your setup tools might be outdated which you can upgrade using pip install --upgrade setuptools

i’am trying to install on windows and also i upgraded the setuptools,but still i’m getting this error

Was this issue fixec?

I am getting a similar issue on mac

I have below version:

(venv) $$ python --version

Python 3.11.2

$ pip --version

pip 22.3.1 from /Users/harish/Downloads/venv/lib/python3.11/site-packages/pip (python 3.11)

pip3 --version

pip 22.3.1 from /Users/harish/Downloads/venv/lib/python3.11/site-packages/pip (python 3.11)

Tried using both pip and pip3 and I got the same error

pip3 install rasa

Collecting rasa Using cached rasa-1.10.2-py3-none-any.whl (510 kB) Collecting PyJWT<1.8,>=1.7 Using cached PyJWT-1.7.1-py2.py3-none-any.whl (18 kB) Collecting SQLAlchemy<1.4.0,>=1.3.3 Using cached SQLAlchemy-1.3.24.tar.gz (6.4 MB) Preparing metadata ( … done Collecting absl-py<0.10,>=0.9 Using cached absl-py-0.9.0.tar.gz (104 kB) Preparing metadata ( … error error: subprocess-exited-with-error

× python egg_info did not run successfully. │ exit code: 1 ╰─> [6 lines of output] Traceback (most recent call last): File “”, line 2, in File “”, line 34, in File “/private/var/folders/0r/k6393gfd5pl4fkg0bzkdqbr80000gn/T/pip-install-d9kwpk5i/absl-py_3816f40e82c943d1868f72ea7c17a558/”, line 34, in raise RuntimeError(‘Python version 2.7 or 3.4+ is required.’) RuntimeError: Python version 2.7 or 3.4+ is required. [end of output]

note: This error originates from a subprocess, and is likely not a problem with pip. error: metadata-generation-failed

× Encountered error while generating package metadata. ╰─> See above for output.

note: This is an issue with the package mentioned above, not pip. hint: See above for details.

Tried the command above:

pip install --upgrade setuptools Requirement already satisfied: setuptools in ./venv/lib/python3.11/site-packages (65.5.0) Collecting setuptools Using cached setuptools-69.0.3-py3-none-any.whl (819 kB) Installing collected packages: setuptools Attempting uninstall: setuptools Found existing installation: setuptools 65.5.0 Uninstalling setuptools-65.5.0: Successfully uninstalled setuptools-65.5.0 Successfully installed setuptools-69.0.3

still the same error