Install rasa-x error

thank you :smiling_face_with_three_hearts:

my rasa --version

@hoangnguyen1222 you need to re-install Anaconda, and need to install fresh environment. Can you please tell me one question, at the time creating conda environment did you separately install ujson and tensor flow?

@hoangnguyen1222 Try this also

conda install -c anaconda ujson


pip install ujson==1.35


Ref this link:

Good Luck!

thank you very much

I installed it successfully but

when i run the command pip install SQLAlchemy==1.3.22

@hoangnguyen1222 what your error now whilst seeing screenshot I am not getting you.

yes, now i’m getting the display error it should be

but when i go to my website it is not responding at all

@hoangnguyen1222 what steps you are using?

here are the steps i do to create rasax 1.conda create -n rasa python anaconda 2.conda activate rasa 3.conda install -c anaconda ujson 4.conda install tensorflow 5.pip install rasa==2.8.1 6.pip install rasa-sdk==2.8.1 7.pip install rasa-x==0.40.0 --extra-index-url Simple Index 8.rasa x

@hoangnguyen1222 Please follow these steps and stick on this please.

  1. conda create --name “Your_Environment_Name” python=3.8 or python==3.7.7

  2. conda activate Your_Environment_Name

  3. pip install rasa==2.8.1

  4. pip install rasa-sdk==2.8.1

  5. rasa init to create the default project

6. pip install rasa-x==0.39.3 --extra-index-url

  1. Error: ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ install

pip install SQLAlchemy==1.3.22

  1. Error: Sanic install

pip install sanic-jwt==1.6.0

  1. Error: Alembic

delete rasa and events .db files and it will automatically created when you run rasa-x

  1. run rasa x and you will be able to see rasa x in your default web browser

If you encounter any error do share me that and then proceed further.

Note: Do follow these steps a fresh approach please.

I wished this time you will be able to install and run rasa.

1 Like

thank you

what files are deleted rasa files ?

@hoangnguyen1222 next time please mention me for a quick reply.

Screenshot 2021-08-25 at 11.21.49 AM

1 Like

thank you so much my rasa x worked

@hoangnguyen1222 you are welcome and many congratulations

1 Like

import as migration_utils File “C:\Users\mridu\Anaconda3\envs\rasa\lib\site-packages\rasax\community\database\schema_migrations\alembic\”, line 12, in from sqlalchemy.engine import reflection, Row, Connection ImportError: cannot import name ‘Row’ from ‘sqlalchemy.engine’ (C:\Users\mridu\Anaconda3\envs\rasa\lib\site-packages\sqlalchemy\

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up. If you need help fixing the issue visit our forum: done everything properly this is what it throws. (rasa) C:\Users\mridu\Desktop\Jarvis_Bot>rasa --version Rasa Version : 2.8.6 Minimum Compatible Version: 2.8.0 Rasa SDK Version : 2.8.2 Rasa X Version : 0.42.2 Python Version : 3.7.0 Operating System : Windows-10-10.0.19041-SP0 Python Path : C:\Users\mridu\Anaconda3\envs\rasa\python.exe

@mridullpandey Please share rasa --version ? @mridullpandey can you please even share the screenshot of error?

@mridullpandey Try install

pip install SQLAlchemy==1.3.22

But, I guess you will still get some new error, but still try.