HTTPS with Rasa X K8s

Version: Rasa X 0.33.0

I have a Rasa X cluster on EKS and am trying to set up HTTPS access to encrypt traffic. Here is the spec section of nginx config:

 spec:
      clusterIP: 10.100.XXX.XXX
      externalTrafficPolicy: Cluster
          ports:
          - name: https
            nodePort: 31493
            port: 443
            protocol: TCP
            targetPort: 8080

When I try to set the protocol to anything besides TCP or UDP it says those are the only two options. So, I receive the following error when trying to connect over HTTPS:

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

I resolved this using the default helm chart by configuring an HTTPS listener on the elastic load balancer to point to the same port as the TCP listener, while keeping the EKS cluster on a private subnet in order to protect all traffic.

There is a guide here:

1 Like