Hi I have trained a model in my local machine and it was working correctly there but when I tried to deploy in Redhat 7 server It was showing me the following error. Please have a look in config file as well

Config.yml language: “en”


  • name: tokenizer_whitespace
  • name: ner_crf
  • name: intent_featurizer_count_vectors OOV_token: oov token_pattern: (?u)\b\w+\b
  • name: intent_classifier_tensorflow_embedding
  • name: ner_duckling_http
  • name: nlp_spacy model: en_core_web_md
  • name: ner_spacy
  • name: Sentiment.SentimentAnalyzer


[myWizardChatbot]$ python3 -m rasa_nlu.train -c config.yml --data FAQ_POC.json -o models

Traceback (most recent call last):

File “/usr/local/lib/python3.6/”, line 193, in _run_module_as_main

"__main__", mod_spec)

File “/usr/local/lib/python3.6/”, line 85, in _run_code

exec(code, run_globals)

File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 184, in


File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 148, in do_train

trainer = Trainer(cfg, component_builder)

File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 155, in init

self.pipeline = self._build_pipeline(cfg, component_builder)

File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 166, in _build_pipeline

component_name, cfg)

File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 441, in create_component


File “/usr/local/lib/python3.6/site-packages/rasa_nlu/”, line 142, in create_component_by_name

return component_clz.create(config)

File “/usr/local/lib/python3.6/site-packages/rasa_nlu/utils/”, line 73, in create

nlp = spacy.load(spacy_model_name, parser=False)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 21, in load

return util.load_model(name, **overrides)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 114, in load_model

return load_model_from_package(name, **overrides)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 135, in load_model_from_package

return cls.load(**overrides)

File “/usr/local/lib/python3.6/site-packages/en_core_web_md/”, line 12, in load

return load_model_from_init_py(__file__, **overrides)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 173, in load_model_from_init_py

return load_model_from_path(data_path, meta, **overrides)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 156, in load_model_from_path

return nlp.from_disk(model_path)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 647, in from_disk

util.from_disk(path, deserializers, exclude)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 511, in from_disk

reader(path / key)

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 643, in

deserializers[name] = lambda p, proc=proc: proc.from_disk(p, vocab=False)

File “pipeline.pyx”, line 643, in spacy.pipeline.Tagger.from_disk

File “/usr/local/lib/python3.6/site-packages/spacy/”, line 511, in from_disk

reader(path / key)

File “pipeline.pyx”, line 626, in spacy.pipeline.Tagger.from_disk.load_model

File “pipeline.pyx”, line 627, in spacy.pipeline.Tagger.from_disk.load_model

File “/usr/local/lib/python3.6/site-packages/thinc/neural/_classes/”, line 352, in from_bytes

copy_array(dest, param[b'value'])

File “/usr/local/lib/python3.6/site-packages/thinc/neural/”, line 70, in copy_array

dst[:] = src

ValueError: could not broadcast input array from shape (96) into shape (128)

it looks like there is some error inside spacy, are you sure, you use the same spacy versions on your machine?

I have the same issue with exactly the same error. Got spacy==2.0.12 @shreyasap - did you find out what you were doing wrongly?

Try downgrading the msgpack version to 0.5.6. Reference: