How to post to rasa server after Rasa X Deployment

I followed this tutorial Deploy Your Assistant and successful to deploy rasa x to GCP. Now i want to connect another UI front-end to rasa server but i can’t find link to request POST method to get the answer.
When i run Rasa X in localhost, i can request to http://localhost:5005/webhooks/rest/webhook to get the answer like this:

This is docker-compose.yml file in my VM instance.docker-compose.yml (4.1 KB)

1 Like

Does replacing “localhost” with the IP address where your assist is being hosted work?

After wait a long time it give this:

I was poking around and it looks like the endpoints are here:

http://example.com/core/webhooks/rest/webhook

Does that work for you?

Now i can see “Hello from rasa” in http://example.com/core/ but i can’t post.
This is what postman receive:


And this is what my server log:
I check my credentials.yml file in /etc/rasa and add rest: but it not work.

1 Like

Are you running a docker-compose install on a GCP VM? Can you confirm that port 80 is open on the VM.

If you ssh into the VM and run the following command what is the response:

curl --location --request POST 'http://localhost:5005/core/webhooks/rest/webhook' --data-raw '{ "sender": "postman", "message": "what is rasa x" }'

Greg

2 Likes

I am running on a GCP VM. sudo ufw status verbose
image


I check docker ps show too

I create another VM and set up again. Before run docker-compose like step 3, i add rest: to credentials file and then i can receive response from http://example.com/core/webhooks/rest/webhook.
Thank you so much @stephens, @rctatman :grinning:

@rctatman @stephens
I am using local mode and trying to connect rasa server with my custom channel using RestInput. I did add /core to my postman request URL like this http://localhost:5005/core/webhooks/rest/webhook (Although currently i am testing it locally, I plan to shift to a domain) I still get the same error. Is it mandatory to run Rasa X server ? Currently i am running rasa server using command rasa run