How to debug HTTPS/SSL not working in Rasa X with docker-compose

I have installed Rasa X using the docker-compose instructions at Docker Compose Installation

The installation is working.

However, trying to enable HTTPS on the installation is not working and I cannot see anything in the logs to give me a clue as to what could be going wrong.

I have step-by-step followed the instructions here: Customize Your Deployment

fullchain.pem and privkey.pem are in the certs directory, and I have chmod 770 them.

When I run docker-compose up, the Rasa X installation is available at the subdomain but not on HTTPS. I don’t see any SSL or HTTPS or .pem related errors in the logs when I run docker-compose logs.

How can I figure out why HTTPS isn’t working? Is there a log somewhere of some component that is looking for the certificate files or something?

From the instructions it seems as though HTTPS should just immediately work after copying the certificates, so I have no idea how to check on what should be happening and why it isn’t in this case.

Any help much appreciated.

2 Likes

I managed to get my Rasa X install working with HTTPS.

There seems to be a gap in the documentation on using HTTPS, at least with docker-compose.

Not mentioned in the docs, I needed to:

  • Uncomment the line include /etc/nginx/conf.d/ssl.conf; in nginx-config-files/rasax.nginx.template
  • Uncomment the lines in nginx-config-files/ssl.conf.template AND adjust them to change the paths /etc/nginx/certs/{fullchain,privkey}.pem to /etc/certs/{fullchain,privkey}.pem.

After this, my Rasa X installation works through HTTPS.

5 Likes

@justyn Thank you ! We have been struggling with this for days !

1 Like

This was the solution! Thank you. Another question, is there a way to put SSL on the REST channel also? is the webhook

Hi, it is already isn’t it, could you elaborate?