Frontend update issue

I’m running my test bots at azure environment
I’m running rasa in docker container and then using webchat widget, as frontend for bot, on apache server.

My issue is that when I make changes in source files, like update some response text, they don’t show up immediately on browser window. If I run rasa locally in shell mode, changes are there. And more strange, changes come to browser after a while???

I’m using rasa 1.10.11

Here is command I use

docker restart “bot docker name”

I suspected first that is was browser cache issue, but I have tried to open bot in two different computers and using different browsers.

I have also tried apache restart too

sudo systemctl restart apache2

But no help? What could I try next?

Found reason, I have 7 chatbots in prod and one in testbed and messed up with configuration files.

This can be CLOSED now

What is your process for updating the model in the Rasa docker container?

This is my process

  1. Stop container docker stop xxxx
  2. Remove container, because I want to keep same name docker rm xxxx
  3. Then update config files, and train rasa docker run -it --rm --user 1003 -v $(pwd):/app rasa/rasa:2.2.0-full train --debug
  4. Run docker container docker run --name=amva --user 1003 -v $(pwd):/app -p “5011:5005” rasa/rasa:2.2.0-full run -m models --enable-api --cors “*” --debug
  5. Check it is working