Formbot error msg: ERROR rasa.core.processor - Encountered an exception while running action 'restaurant_form'. Bot will continue, but the actions events are lost. Make sure to fix the exception in your custom

Hi

I just downloaded the latest Rasa release, and I am playing with the formbot example with Rasa 1.0.

Here are the commands I issued:

  1. rasa train
  2. run -p 8000:8000 rasa/duckling
  3. rasa run actions&
  4. rasa shell -m models --endpoints endpoints.yml

Rasa fired up, but when I entered the utterance

I am looking for a restaurant

I got the following

WARNING: The TensorFlow contrib module will not be included in TensorFlow 2.0. For more information, please see:

2019-06-07 14:07:12 INFO root - Starting Rasa Core server on http://localhost:5005 2019-06-07 14:07:12.545783: I tensorflow/core/platform/cpu_feature_guard.cc:141] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA 2019-06-07 14:07:12.565803: I tensorflow/core/platform/profile_utils/cpu_utils.cc:94] CPU Frequency: 3696000000 Hz 2019-06-07 14:07:12.565988: I tensorflow/compiler/xla/service/service.cc:150] XLA service 0x55b1818cb220 executing computations on platform Host. Devices: 2019-06-07 14:07:12.566005: I tensorflow/compiler/xla/service/service.cc:158] StreamExecutor device (0): , Bot loaded. Type a message and press enter (use ‘/stop’ to exit): Your input -> hi
Hello! I am restaurant search assistant! How can I help? Your input -> i am looking for a restaurant
[2019-06-07 14:08:08 -0700] [26985] [ERROR] Exception occurred while handling uri: 'http://localhost:5005/webhook Traceback (most recent call last): File “/home/shogo/miniconda3/envs/rasa/lib/python3.6/site-packages/sanic/app.py”, line 893, in handle_request handler, args, kwargs, uri = self.router.get(request) File “/home/shogo/miniconda3/envs/rasa/lib/python3.6/site-packages/sanic/router.py”, line 407, in get return self._get(request.path, request.method, “”) File “/home/shogo/miniconda3/envs/rasa/lib/python3.6/site-packages/sanic/router.py”, line 469, in _get raise NotFound(“Requested URL {} not found”.format(url)) sanic.exceptions.NotFound: Requested URL /webhook not found 2019-06-07 14:08:08 ERROR rasa.core.processor - Encountered an exception while running action ‘restaurant_form’. Bot will continue, but the actions events are lost. Make sure to fix the exception in your custom code. I am going to run a restaurant search using the following parameters:

  • cuisine: None
  • num_people: None
  • outdoor_seating: None
  • preferences: None
  • feedback: None Your input ->

Cancelled by user

Any advice or pointer is much appreciated.

J

Hey @studiocardo,

can you provide us the content of your endpoints file?

Regards

Hi Julian

Thx for checking in!

As requested…

> shogo@ubuntu16:~/Rasa/rasa-master/examples/formbot$ cat endpoints.yml 
> action_endpoint:
>     url: http://localhost:5005/webhook

It’s the same as the repot. I did issue “rasa run actions&” and could confirm that it’s running in the background…

Thanks, J

Hi @studiocardo,

I will investigate this as soon as I am home and keep you updated.

Regards

Hi @studiocardo,

I investigated as promised the problem. I think the restaurant bot is a deprecated example. As you might not have seen, there is a bot.py which, besides other important settings, defines a RestaurantPolicy which is extra precisely targeted to the restaurant case. By using the rasa 1.0 commands, this shouldnt have worked properly because rasa then uses a fallback to a config file which does not incorporate the custom modelling.

If you really want to use this bot, you have to adapt the modifications in bot.py and policy.py or you have to switch back to an older rasa version.

Do you simply need a demo?

Regards Julian

Hi Julian

Thanks for looking into this.

Yes, pls advise how to downgrade to 0.14, that would be the easiest route for me. I can’t find the instructions to do so.

Thank you for your help.

Best, J

Hi Julian

I created a new virtual environment and attempted to install the previous version of Rasa nlu and core. The installation went through as expected, but I got a bus error (core dump) if I tried to do anything wrt Rasa… So it looks like going back to the old version is not as easy as I thought.

Nonetheless, I just redownloaded the github repot and rebuilt and ran the formbot. And it appears to have been fixed and working now.

J

Hi @studiocardo,

okay - glad to hear. Sometimes it’s unpredictable! :slight_smile:

Feel free to ask for help at anytime.

Regards

hi can you please help me