Failed to find component class for 'SpacyNLP'

I am using a very basic pipeline: language: “en”


  • name: “SpacyNLP”
  • name: “SpacyFeaturizer”
  • name: “EmbeddingIntentClassifier” intent_tokenization_flag: true intent_split_symbol: “+”

I get this error. Exception: Failed to find component class for ‘SpacyNLP’. Unknown component name. Check your configured pipeline and make sure the mentioned component is not misspelled. If you are creating your own component, make sure it is either listed as part of the component_classes in or is a proper name of a class in a module.

Hi @agarwalmridul09, I tried to copy your pipeline config and I got the same error as you, but it was caused by the opening and closing double quotes (i.e. the and the ). I know that these symbols also depend on the internet browser, so I am not 100% sure if this is causing the error on your end, but could you try to remove the double quotes entirely from your config file (perhaps enclosing the intent split symbol in simple quotes like " or ') and try to run it again?