How should be pipeline on New Version

In the new version is entering these two values as the pipeline

  - name: "intent_featurizer_count_vectors" 
  - name: "intent_classifier_supervised_embeddings" 

but i can get the following error:

Failed to find component class for 'intent_classifier_supervised_embeddings'. Unknown component name. Check your configured pipeline and make sure the mentioned component is not misspelled. If you are creating your own component, make sure it is either listed as part of the component_classes in or is a proper name of a class in a module

If I just enter supervised embeddings I am not getting any error as below:

pipeline: "supervised_embeddings"

Should i type the count_vectors , intent_entity_featurizer_regex or ner-crf ? Or just type supervised_embeddings

Hm, this is strange, normally the error message should tell you how the first one has been renamed. In the new style: "intent_featurizer_count_vectors" --> "CountVectorsFeaturizer" as for "intent_classifier_supervised_embeddings", that never existed. Here you can find all of the new names, and the mappings from old to new can be found here.

1 Like

Thanks @erohmensing . I’ve tried intent_classifier_tensorflow_embeddings first. But again when I get the same error. I thought it might be like this intent_classifier_supervised_embeddings.

The top of the first link I gave you has the pipeline name changes:

For clarity, we have renamed the pre-defined pipelines to reflect what they do rather than which libraries they use as of Rasa NLU 0.15. The tensorflow_embedding pipeline is now called supervised_embeddings , and spacy_sklearn is now known as pretrained_embeddings_spacy . Please update your code if you are using these.

I updated. it is work thanks again

1 Like