Error while initializing rasa

I tried rasa init and this came up:
I am using python version 3.8 and rasa version 2.6

(chatbots) C:\Users\muhammadhussain\Desktop\chatbot-rasa>rasa init Welcome to Rasa! :robot:

To get started quickly, an initial project will be created.
If you need some help, check out the documentation at
Now let's start! πŸ‘‡πŸ½

? Please enter a path where the project will be created [default: current directory]
? Directory 'C:\Users\muhammadhussain\Desktop\chatbot-rasa' is not empty. Continue?  Yes
Created project directory at 'C:\Users\muhammadhussain\Desktop\chatbot-rasa'.
Finished creating project structure.
? Do you want to train an initial model? πŸ’ͺ🏽  Yes
Training an initial model...
Traceback (most recent call last):
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\", line 87, in _run_code
    exec(code, run_globals)
  File "C:\Users\muhammadhussain\Miniconda3\envs\chatbots\Scripts\rasa.exe\", line 7, in <module>
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\", line 117, in main
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\cli\", line 235, in run
    init_project(args, path)
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\cli\", line 130, in init_project
    print_train_or_instructions(args, path)
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\cli\", line 69, in print_train_or_instructions
    training_result = rasa.train(domain, config, training_files, output)
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\", line 106, in train
    from rasa.model_training import train_async
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\", line 22, in <module>
    from rasa.nlu.model import Interpreter
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\nlu\", line 14, in <module>
    from rasa.nlu import components, utils
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\nlu\", line 7, in <module>
    import rasa.utils.train_utils
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\utils\", line 37, in <module>
    from rasa.utils.tensorflow.callback import RasaTrainingLogger, RasaModelCheckpoint
  File "c:\users\muhammadhussain\miniconda3\envs\chatbots\lib\site-packages\rasa\utils\tensorflow\", line 5, in <module>
    import tensorflow as tf
  File "C:\Users\muhammadhussain\AppData\Roaming\Python\Python38\site-packages\tensorflow\", line 41, in <module>
    from import module_util as _module_util
  File "C:\Users\muhammadhussain\AppData\Roaming\Python\Python38\site-packages\tensorflow\python\", line 40, in <module>
    from tensorflow.python.eager import context
ModuleNotFoundError: No module named 'tensorflow.python.eager'

@syedhussain Heya! Please share the screenshot of error. OR update

pip install tensorflow

If still issue persist please share the rasa version also

rasa --version

@syedhussain Does it help to fix you problem?

i have already installed tensorflow i tried to follow this installation guide but the issue persists

rasa --version result:

Rasa Version      :         2.7.1
Minimum Compatible Version: 2.6.0
Rasa SDK Version  :         2.7.0
Rasa X Version    :         None
Python Version    :         3.8.0
Operating System  :         Windows-10-10.0.19041-SP0
Python Path       :         c:\users\muhammadhussain\miniconda3\envs\rasa\python.exe

@syedhussain Can you share the screenshot please. I am here :slight_smile:

@syedhussain can share the screenshot of tensorflow and tensor board all will be in sequence when you run this command:

pip list

@syedhussain Update tensorboard, will solve this step by step ok?

pip install tensorboard==2.5.0 and run and share the error if persist ok? only share the tensorflow version from the screen.

@syedhussain pip install tensorflow==2.3.3 :slight_smile: extra step if error still now send me the screenshot off error please :slight_smile:

This is what i got when i ran pip install tensorboard==2.5.0

I also ran pip install tensorflow==2.3.3

I tried training rasa but I got the ModuleNotFoundError: No module named 'tensorflow.python.eager' again


pip install scipy==1.4.1 please and run again

same error still coming


tried installing rasa version 2.6.2 with poetry and it worked fine, I still don’t know what the actual error was, but it is training now.

@syedhussain It will solve you issue for a time?

@syedhussain What I suggest do it tomorrow ok. If still the problem persist. I will assist you further. Do install Anconda.

@nik202 sure