Error when running rasa x command on Windows 10 - help plz

Starting Rasa X in local mode… :rocket: Traceback (most recent call last): File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasa\cli\x.py”, line 431, in run_locally args, project_path, args.data, token=rasa_x_token, config_path=config_path File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasax\community\local.py”, line 186, in main app = rasa_x_server.configure_app() File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\app.py”, line 206, in configure_app app.blueprint(interface.blueprint()) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py”, line 119, in blueprint interface_directory = locate_interface() File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py”, line 104, in locate_interface return build_interface() File “c:\users\jpvgc\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py”, line 80, in build_interface p.start() File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\process.py”, line 112, in start self._popen = self._Popen(self) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\context.py”, line 223, in _Popen return _default_context.get_context().Process._Popen(process_obj) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\context.py”, line 322, in _Popen return Popen(process_obj) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\popen_spawn_win32.py”, line 89, in init reduction.dump(process_obj, to_child) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\reduction.py”, line 60, in dump ForkingPickler(file, protocol).dump(obj) AttributeError: Can’t pickle local object ‘build_interface..run_build’

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up. If you need help fixing the issue visit our forum: https://forum.rasa.com/. Traceback (most recent call last): File “”, line 1, in File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\spawn.py”, line 105, in spawn_main exitcode = _main(fd) File “c:\users\jpvgc\anaconda3\envs\rasa\lib\multiprocessing\spawn.py”, line 115, in _main self = reduction.pickle.load(from_parent) EOFError: Ran out of input

@jpvgc45 I am facing same issue. If you find any solution. let me know.

1 Like

@jpvgc45 I am also facing same issue. Please help

2 Likes

@juste Please reply I am also facing this issue.

1 Like

To run Rasa X on Windows 10, it is recommended to use docker.

See the Rasa X documentation on Docker Compose Manual Install

Hi guys,

I had similar issue in the past. obviously the best solution is using docker, but it can still work on windows.

my solution was to create new enviroment and then install the rasa-x using this command: pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

I tried to fix the old enviorment but something between the rasa-x version to the rasa core version crashed.

hello every one .I was facing same issue but now it solved. If you want to run rasa x in local . please install rasa x version 0.27.2 . it works fine .

This version not found and I am still getting the same error