Not able to open Rasa X in windows 10

I have tried Python version 3.6 ,3.8 and now 3.7 , created multiple new environments and still could not solve this error , Rasa is working fine but no matter what im trying Rasa x i cant get to work , at the verge of giving up on this !!

(rasaenv) C:\Users\aiyap\Desktop_Local\Rasa_X_reinstall>rasa --version Rasa Version : 2.8.1 Minimum Compatible Version: 2.8.0 Rasa SDK Version : 2.8.1 Rasa X Version : 0.42.0 Python Version : 3.7.11 Operating System : Windows-10-10.0.19041-SP0 Python Path : c:\users\aiyap\anaconda3\envs\rasaenv\python.exe

(rasaenv) C:\Users\aiyap\Desktop_Local\Rasa_X_reinstall>rasa x Starting Rasa X in local mode… :rocket: 2021-08-03 11:36:02 WARNING - No local evaluation result files found. Traceback (most recent call last): File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasa\cli\”, line 502, in run_locally domain_path=domain_path, File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\”, line 257, in main common_utils.run_in_loop(model_service.discover_models()) File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\utils\”, line 900, in run_in_loop return loop.run_until_complete(coro) File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\asyncio\”, line 587, in run_until_complete return future.result() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 821, in discover_models await model_service.discover_models() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 147, in discover_models await _run_loop(max_retries, sleep_in_seconds) File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 133, in _run_loop await self._discover_models() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 185, in _discover_models minimum_version = await self._retry_fetching_minimum_compatible_version() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 174, in _retry_fetching_minimum_compatible_version minimum_version = await self.minimum_compatible_version() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 160, in minimum_compatible_version info = await stack_service.version() File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\rasax\community\services\”, line 110, in version timeout=timeout_in_seconds, File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\aiohttp\”, line 582, in _request break File “c:\users\aiyap\anaconda3\envs\rasaenv\lib\site-packages\aiohttp\”, line 596, in exit raise asyncio.TimeoutError from None concurrent.futures._base.TimeoutError

@Pavan_Aiyappa Hi, as I can see your Rasa-X version is 0.42.0 please follow this step.

Downgrade to rasa-x==0.39.3

pip install rasa-x==0.39.3 --extra-index-url

Some known errors:

ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ try running pip install SQLAlchemy==1.3.22 should fix it.)

And, if you get an error not being able to import yaml then run pip install pyyaml.

I hope, this will solve your issue. Good Luck!

@Pavan_Aiyappa Are you able to solve?

Sorry was occupied , i was able to fix the issue which your instructions , Thank you :slight_smile: , still some exceptions it throws but Rasa X works now with my configuration , hope in future we will have hassle free installation experience , i spent lot of hours trying to debug this on my own with solutions on internet no clear one solution worked . Thank you again :slight_smile: