Error rasa init when enter a path

Hi. when I ran the command, it still ask for the path, but when i press enter, there’s an error like this. how to solve?

(Welcome to Rasa! :robot:

To get started quickly, an initial project will be created. If you need some help, check out the documentation at Introduction to Rasa Open Source. Now let’s start! :point_down:t4:

? Please enter a path where the project will be created [default: current directory] Traceback (most recent call last): File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\distutils\”, line 70, in mkpath os.mkdir(head, mode) FileNotFoundError: [WinError 2] The system cannot find the file specified: ‘actions’

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\”, line 194, in _run_module_as_main return run_code(code, main_globals, None, File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\”, line 87, in run_code exec(code, run_globals) File "C:\Users\KAIROS\anaconda3\envs\tugasakhir\Scripts\", line 7, in File "c:\users\kairos\anaconda3\envs\tugasakhir\lib\site-packages\", line 117, in main cmdline_arguments.func(cmdline_arguments) File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\site-packages\rasa\cli\”, line 235, in run init_project(args, path) File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\site-packages\rasa\cli\”, line 128, in init_project create_initial_project(path) File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\site-packages\rasa\cli\”, line 136, in create_initial_project copy_tree(scaffold_path(), path) File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\distutils\”, line 157, in copy_tree copy_tree(src_name, dst_name, preserve_mode, File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\distutils\”, line 135, in copy_tree mkpath(dst, verbose=verbose) File “c:\users\kairos\anaconda3\envs\tugasakhir\lib\distutils\”, line 73, in mkpath raise DistutilsFileError( distutils.errors.DistutilsFileError: could not create ‘actions’: The system cannot find the file specified

Hello @elmoningka ! Can you please share the rasa --version whilst running in your environment and share the screenshot please.

1 Like

hi! this is my version and also my error. yesterday when i turned off my windows defender, i can run my rasa init successfully. but now, even if i turn off my windows defender, it shows some error. this is the screenshot.

@elmoningka Hi, its strange behaviour can you please downgrade rasa version to rasa 2.8.2

pip install rasa==2.8.2

and try run the code

1 Like

i’m done with downgrade rasa version, but it still have the same error. should i downgrade the rasa x too?

Your image shows you have conflicting dependencies (in red).

Try to install Rasa and Rasa X at the same time:

pip install --upgrade rasa rasa-x -i

and check if you still have an error

1 Like

yeah it still have the same error

Still an error, but not the same :slight_smile:

Now try

pip uninstall ujson
pip install --upgrade rasa rasa-x -i --use-feature=2020-resolver

as suggested in the error

1 Like

@elmoningka can you even downgrade the rasa x version to

pip install rasa-x==0.39.3 --extra-index-url

If you encountered new error, please share the screenshot and please mention @ and name.


1 Like

@ChrisRahme i alr uninstalled json, and for the second command i’ve got error like this.

this is the error that i got with that command @nik202

@elmoningka this is when you run my suggested command ?

1 Like

@nik202 yup, that’s the error when i try to downgrade the rasa x

@elmoningka that’s very strange, I guess you need to create new virtual environment. I will share the code you need to follow:

Step1: create a fresh conda environment with python 3.7 or 3.8

activate conda environment conda activate <your environment>


`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

Step3: check rasa is install or not using rasa --version

Step4: then run rasa init

1 Like

@nik202 wow thankyou for the steps! :smiley: btw, from my references video, there’s a step where I have to install ujson and tensorflow. should i do that or not?

@elmoningka Please create environment like this nothing to add or delete.

  1. conda create -n “Your_Environment_Name” python=3.8
  2. conda activate Your_Environment_Name
1 Like

It says here you have to install Visual C++ 14 or greater

@nik202 hi! thankyou for the steps and my rasa init finally works well, but i have to turn off my windows defender. is it okay?

@elmoningka congrts finally, it’s fine; can I request please close this thread with the solution for other users. Thanks.

@nik202 i’m sorry but since i’m a new user so idk how to do it. can you explain?