[Error] Migrate Dialogflow v2 to Rasa


I’m trying to migrate my Dialogflow agent to Rasa, it’s using v2 format.

I followed the tutorial here: Rasa as open source alternative to Google Dialogflow - Migration Guide

But when I run the command rasa train nlu, I got this error message:

  File "/rasa/venv/lib/python3.7/site-packages/rasa/nlu/training_data/formats/dialogflow.py", line 91, in _extract_entity
    entity_type = chunk.get("alias", chunk["meta"])
KeyError: 'meta'

I’ve also tried this command: rasa data convert nlu --data data/ChatbotDialogflow/ --out data/nul.md --format md But got the same problem.

What could be the issue? Using v2 format?

Hi, To anyone else facing the same issue, seems that the usersays json of the intents has only “meta” under entity attributes instead of both “meta” and “alias” attributes (where “alias” refers to entity name and “meta” refers to entity type). Try fixing it by checking your entities and its mapping in Dialogflow UI. Migration of Dialogflow V2 to Rasa worked for me when I fixed this. Hope it helps.

1 Like