Duplicated responses after reconnecting Rasa X to Github

Hey there,

all of my responses in Rasa X automatically got duplicated after I reconnected it with Github. It seems like only one of every pair is synchronized with Github, while the other one is from the old storage before the connection was established. So I tried to solve this manually: After marking all my responses in Github (by making slight changes in the text), I was able to clearly identify them – and also the old ones – in Rasa X. I then manually deleted each one of the old responses without a marking in Rasa X. Now I unmarked my responses on Github again but these changes of my domain are not transferred to Rasa X anymore, although it was a commit without any errors.

Does anyone have an idea, what might be the problem here?

Thanks in advance!

1 Like

Did you solve this issue?

Hey @yash0359

To be honest I am not sure anymore how I solved it. I think it was by simply updating Rasa X version or by re-uploading my data to Github and synching it with a re-installed and β€œcleared” version of Rasa X. It never happened again since then so I suppose it was an issue connected to an older version of Rasa X.