Does rasa only work with python 3.7 and 3.8 - have had issues with 3.10


I am trying to install rasa in a virtual environment. I installed python 3.10 and when running rasa init, an error is being thrown while installing and rasa is never fully installed.

Was just wondering if it’s a python version problem?


This is documented in the install. 3.7 or 3.8.

Ok thanks. I uninstalled 3.10 and have 3.8 installed. This is on Windows 11. I’ve previously installed rasa on an old laptop a little while back and it worked, but am now running into all sorts of errors with pip while following the installation docs. I’ve tried installing rasa in a virtual environment and running rasa init but no success so far. There are errors to do with a package called randomname , and other ssl errors such as:

ERROR: Can not perform a ‘–user’ install. User site-packages are not visible in this virtualenv. WARNING: pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.

I have Anaconda installed and have tried to install rasa into a virtual environment through Anaconda but didn’t work.

I’ve had a look at stackoverflow but haven’t succeeded yet. Thx

If anyone runs into similar issues on Windows - I ended up installing in an Anaconda virtual environment. The rasa docs say to run pip3 install -U --user pip && pip3 install rasa - basically just split that up and ran python.exe pip3 install -U --user pip and then pip3 install rasa, then rasa init and it worked. This is with python 3.8.